A fresh install of VMWare Workstation 7 (7.1.1 build 282343) on Windows 7 64 bit.

When I try to read a CD/DVD from a guest (either to install a fresh guest or to read a CD within an existing VM I get the following error: Cannot connect virtual device ide1:0 because no corresponding device is available on the host.

I've tried fiddling with the IDE channels as well as tried SCSI with no joy. What am I missing?

I can run ISOs fine but I don't want to have to convert everything to an ISO when I presume that this should just work fine.


Turned out to be a fairly simple fix... I opened up the host and connected the DVD drive in to a different SATA socket and VMWare saw it as soon as I started it up again. A bit strange as I didn't think SATA sockets had anything like the primary/secondary concept like IDE but at least it's resolved the problem.

  • Thanks folks. This answer solved my problem as well. I'm using Windows 7 Pro on a Thinkpad W520 laptop with VMWare Workstation 7.1.5. I've been getting this error (Cannot connect virtual device ide1:0 because no corresponding device is available on the host.) for a while and could not figure out why or what to do about this. The suggested solution makes sense and immediately resolved my issue. Thanks much. You saved me more frustration and wasted time. – user156746 Sep 6 '12 at 15:23

I had the same problem. Fresh install of VMware Workstation 7.1.5 on Windows 7 64bit. Whenever I tried to read a CD/DVD on a guest I would get the error: Cannot connect virtual device ide1:0 because no corresponding device is available on the host. No matter if I was installing an OS from scratch or booting to a boot CD or installing software on a running guest. I tried copying another VM from another PC running VMWare Workstation 7. Same issue. I tried copying VMs from PC running VMware Server 2.0.2. Same error. Nothing helped. Also found that EVERY VM on the system had same dropdown selection for hardware device "CD/DVD IDE" - AutoDetect. No drive letter available, only "AutoDetect". I tried changing the IDE settings to every option available including LEGACY. I tried SCSI settings, nothing helped.

After reading this post, I thought of another fix. I went into device manager (right click My Computer - Manage - Device Manager) and deleted (uninstalled) the CD/DVD ROM device. Then right click on My Computer at top of Device Manager list of devices and select "Scan for Hardware Changes". Bingo!!!

Now all VMs have a Drive letter in the CD/DVD IDE device - AutoDetect and E:. Now every VM can access the CDROM drive and boot to the CD/DVD drive if needed.

Very frustrating problem and VERY glad to have found a solution.


This is how I accomplished it on a new W530 with Windows 8 Pro in which VMWare 9 was not finding the DVD drive:

  1. I put a DVD in the drive
  2. I looked at the device list to find the driver
  3. Uninstalled the driver
  4. Rebooted with the DVD in the drive
  5. Booted up VMWare

Voilà! VMWare finds drive D:.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.