6

I'm running Arch. I don't have Apache or any other web server installed. Accessing localhost:8080, I get a plaintext response:

it works

No HTML, nothing. I don't know what process is serving this. lsof -i :8080 gives nothing, as does ps aux | grep 8080, as does ss -ap | grep 8080.

How can I find what process is providing this and terminate it?

4
  • 1
    What nftables or iptables rules do you have? Feb 27, 2023 at 12:07
  • 4
    What's the output of netstat -tulpn | grep 8080? Please don't answer in comments, but edit your question instead. That way all the relevant info is readily available. Feb 27, 2023 at 12:08
  • @Peregrino69 done. it showed lighttpd. problem solved, and I added it as an answer (unfortunately I can't accept it yet and have to wait 2 days). thank you for your help :)
    – theo
    Feb 27, 2023 at 12:42
  • You's most welcome :-) Feb 27, 2023 at 12:47

1 Answer 1

5

After installing netstat and running sudo netstat -tulpn | grep 8080, I get:

tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      661/lighttpd

I can then sudo systemctl stop lighttpd and the issue is solved.

Thanks to @Peregrino69 for pointing me to this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .