1

VMWare Workstation: 17.01 Guest OS: Windows 10.

After upgrading host Ubuntu 20.04 => 22.04, VMWare Workstation copy/paste function is broken.

  • Host => Guest: Copy/Cut text: unable to paste in guest.
  • Host => Guest: Copy/Cut file: unable to paste in guest.
  • Guest => Host: Copy/Cut text: working.
  • Guest => Host: Copy/Cut file: file copied to host, but cut does not delete file in guest.
  • Host => Guest: drag file: working.

What I tried:

  • Reinstall VMWare Tools.
  • Reinstall VMWare on host.
  • Reboot.

==== UPDATE ====
It seems to be a host desktop integration problem (bug?) -- copy from some apps works.
For example:

  • Copy from Chrome and paste to guest => working.
  • Copy from gedit/terminal/calculator => cannot paste.
    The file copy/paste was from nautilus, so it might work from other file manager.
2
  • My guess would be that it's due to X11 having separate clipboards.
    – jamesdlin
    Mar 2, 2023 at 7:32
  • @jamesdlin It could be related, but not obvious why. wl-paste and xclip -o always seems to yield same text, no matter it is copy from chrome or gedit. Mar 2, 2023 at 12:32

2 Answers 2

0

VMware Workstation had an upgrade just recently.

This should have triggered an upgrade to VMware Tools in guest machines.

Use the VMware Workstation Menu to do a manual reinstall of VMware Tools in the Windows 10 Guest machine. I have a Windows 10 Guest machine here in VMware Workstation V17 and the manual reinstall should work.

Restart Guest and Host after doing the reinstall.

It may be necessary to reinstall VMware itself in the Ubuntu Host machine. Uninstall, restart and install / patch. Make sure VMware is the newest version (V17)

2
  • I updated vmware tools just now and host-to-guest pasting is still broken. I tried to reinstall tools & reinstall vmware. Feb 27, 2023 at 15:02
  • Make sure you restarted the host between uninstall and reinstall. Also upgrade VMware to the newest version.
    – John
    Feb 27, 2023 at 15:05
0

Host to guest pasting not working in VMware Workstation after upgrading the host to Ubuntu 22.04? Don't worry - this is a known bug and there's an easy fix!

The main cause of this issue is the fact that many of the packages that are necessary for seamless copy-pasting from host to guest have been removed from Ubuntu 22.04 due to security reasons. This means you can't just update your VMWare Workstation installation like you used to do before without running into this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .