I'm trying to forward my local server running on XAMPP on port 80 to be available on my IPv4 address. I created a new entry, with these details:

image of the entry

but when I enter my IPv4 address I only see this page

router page

with the login and password.

What can I do to fix this?

  • 2
    Accessing the web server public IP from your private network will only work if your router supports NAT Reflection/NAT Loopback/NAT Hairpinning? - NYC Networkers. Most consumer grade routers don't.
    – DavidPostill
    Mar 4 at 14:37
  • 1
    Ask a friend to try to check if they can get to your server. If that works, the config is correct. If you want to access it from internal network, you need to go to Mar 4 at 14:49

1 Answer 1


Usually, you need to set up TCP for the HTTP protocol (there are some exceptions though).

However as Peregrino69 states correctly some consumer-grade routers will require you to use the internal address when you try to access the forwarded port (otherwise they route you to the router's HTTP-server). On some routers even if this isn't enough, then your only option is to use a different port for your xampp server. I've seen this behavior on several models.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.