I am in the process (almost done) of migrating a website from an on-prem server onto a server in the cloud. When I type in the URL, a response comes back "this site can't be reached", and the URL has changed from the subdoman/domain name I entered into the browser to the correct path, but with the internal IP instead of the domain name.

When I then change this again (to https://subdomain.domain.tld/), the site that I wanted to visit pops up.

I am suspecting some error in a setting on the server, but I don't know exactly where to look.

I have set up a virtual host file for the site, and there I have configured <VirtualHost [internal IP address]:443> ServerName [fully qualified domain name]

When I change the entry so it says <VirtualHost [fully qualified domain name]:443>, I get an error ERR_BAD_SSL_CLIENT_AUTH_CERT

The fact that the certificate is accepted when I try a second time with the internal IP in the virtual host file tells me there's not really anything wrong with the certificate.

Where else can I look?

  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Mar 7 at 11:00
  • are you using virtualhosts?
    – Journeyman Geek
    Mar 7 at 11:04
  • I am using virtualhosts. I've edited the question to elaborate on that.
    – Bokkie
    Mar 7 at 11:24

1 Answer 1


I've resolved the issue... The application I am hosting is a mediawiki. Mediawiki has a variable "$wgServer", which also needs to point to the FQDN... After setting that, all is well.

What did I do to find this "bug"? I looked for the internal IP in all possible paths in Linux First /etc/, which gave me /etc/httpd/conf.d/ Then /var/www/, where the application is located. There I found it in /var/www/mediawiki-1.39.0/LocalSettings.php.

Thanks for the temporary use of your braincells. ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.