I enable promiscuous mode on hyper-V system(windows 11) following by hypervPromiscuousModeSetUp

I test wireshark on hyper-v running Kali linux OS, It works well.

But, I want to disable promiscuous Mode on hyper-v system now. How can I disable promiscuous Mode on hyper-v system?

Thank you.

  • 1
    Change the monitor mode setting to non-monitoring in the instructions you linked to.
    – anon
    Commented Mar 9, 2023 at 16:36

2 Answers 2


The complications and limitations of the PowerShell cmdlets outlined above led to writing a simplified set of PowerShell commands, where enabling port monitoring on external or internal switches gets as simple as:

Import-Module .\VMSwitchPortMonitorMode.psm1

Set-VMSwitchPortMonitorMode -SwitchName MySwitch -MonitorMode Source

The module is available here

How to check the status of port monitoring on a given switch:

PS C:\Dev> Get-VMSwitchPortMonitorMode MySwitch
PortType   MonitorMode
--------   -----------
External   Source>

Disabling monitoring is also very easy:

Set-VMSwitchPortMonitorMode -SwitchName MySwitch -MonitorMode None

Source: https://cloudbase.it/hyper-v-promiscuous-mode/


According to the article Configure traffic mirroring with a Hyper-V vSwitch MonitorMode=0 means "None".

It might be simpler to just create the switch anew in normal mode.

  • Thanks for giving advice. As the article, only set MonitorMode=2 as work as promiscuous Mode? hypervPromiscuousModeSetUp Here says that set MonitorMode=2 and also set physical mac address on host computer to do port mirroring. I already set port mirroring with my physical mac address, so I wonder that just change MonitorMode=0 can disable premiscuous mode.
    – Yang
    Commented Mar 10, 2023 at 14:56
  • and According to the article configure traffic mirroring with a hyper-v vswitchhyperV does not needed port mirroring to work as premiscuous mode, only needed monitorMode=2 right? I'm so confused why hypervPromiscuousModeSetup teaches to set port mirroring.
    – Yang
    Commented Mar 10, 2023 at 15:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .