1

Trying to get my Raspberry Pi 4B to boot from USB.

I'm following the official instruction on Pi website, that means I'm using the USB imager app on my Mac. I load up ver 11 onto a new NVMe drive I bought and plug it into USB port of the Pi (I tried both usb2 and usb3 ports)

The install hangs and I see message trying boot mode USB MSD.

I can also go into diagnostics screen and see

boot mode usb-msd (04) order f
usb msd stopped - timeout. 

I'm guessing my EEPROM doesn't need to be modified since its trying the USB? The Pi imager on Mac didn't give me any error when I created the image on the nvme drive

What else can I do?

1
  • 1
    I would first try a USB thumb drive, see if the pi boots from that. When booted in the pi (SD or thumb drive) attach the USB drive you have an issue with, and run lsusb and add the output to the question - also run dmesg just after connecting the USB drive you have an issue and check the last few lines (20 or so) Mar 12, 2023 at 21:51

2 Answers 2

1

Since it tries to boot from USB drive, the EEPROM is correctly set.

What you need to do is

  1. Create a regular RasPi OS SD card
  2. Insert the card to the RasPi
  3. Boot up
    • it will first attempt to boot from the USB for 10 sec or so
    • when this fails it will boot from the SD card as usual
  4. When the OS is running, insert the NVMe drive to the USB3 slot
  5. Go to Start -> Accessories -> SD Card Copier

copier

  1. Choose the SD card as "Copy From" -device and "External USB" as "Copy To" -device

CopyTo

  1. When the copy is finished shut the RasPi down, remove the SD card and power up

RasPi will now boot from the NVMe connected to the USB slot. Any changes in settings, updates etc. will be also be copied.

1
  • 1
    Isn't this just an alternate way to create a Pi image on the USB drive? How will that fix the timeout trying to initially read the USB drive? Mar 12, 2023 at 21:49
0

I was able to confirm the problem was the USB cable. You need a quality USB-C to USB-A cable to connect an external SSD enclosure.

I tried several USB-C to USB-A cables but only one was able to successfully connect my Pi or my MacBook to the SSD enclosure.

2
  • 1
    This is only partially true, it isn't necessarily the quality. Its also the version. The USB-B cable has had three incarnations. The second one supports a fast connection and its only the latest one that supplies more power. See Mar 13, 2023 at 3:36
  • sorry, i meant to say USB-C to USB-A cable was the source of my problem. I edited the offending comment. regarding these USB-A cables... it seems that most of them i have are cheapy cables that came with products for teh purpose fo supplying power. when i try to use them to connect an ssd drive to pi4, they simply didnt work for transferring data at all. i had to keep trying different ones until i found one that worked. there are no markings on these differnt usb-a cables to indicate which work for data Mar 13, 2023 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .