0

I used to use Atom as my editor, but recently switched over to VSCode. When I used to use Atom, I could right click on a file from FileZilla, click on "View/Edit" and it would open in Atom without any issues. Since I've switched to VSCode it just will not open files from FileZilla. VSCode itself opens and focuses when FileZilla has finished downloading a file but it won't open the actual file. I've tried changing my FileZilla filetype associations, default/customer editor settings and so on but to no avail. Filetype associations that I've tried are:

css "/Applications/Visual Studio Code.app" %f
html "/Applications/Visual Studio Code.app" %f
js "/Applications/Visual Studio Code.app" %f
php "/Applications/Visual Studio Code.app" %f
css "/Applications/Visual Studio Code.app" -open
html "/Applications/Visual Studio Code.app" -open
js "/Applications/Visual Studio Code.app" -open
php "/Applications/Visual Studio Code.app" -open
* "/Applications/Visual Studio Code.app" %f
* "/Applications/Visual Studio Code.app" -open

But none of these work. Has anyone had a similar issue and been able to find a fix?

EDIT

I forgot to mention that I'm working on Mac (Big Sur)

2
  • Have you in Filezilla > Settings > Filetype Associations made sure that all of the necessary file-types are associated with VS Code?
    – harrymc
    Mar 14, 2023 at 11:56
  • Yes I think so, I tried adding the filetype associations as mentioned in my question but it still won't open PHP files
    – AJT
    Mar 14, 2023 at 13:55

1 Answer 1

1

Its because FileZilla doesn't have permissions to the location that the file is being downloaded to. Since 10.15 Catalina default security has been tightened up a lot, apps don't get permission to everything by default. I had the same problem and this fixed it.

  1. Click on the Apple menu icon apple menu and select System Preferences.
  2. Select the Security & Privacy section.
  3. Click on the Privacy tab, then select the Files and Folders.
  4. Give FileZilla permission to access the Downloads folder

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .