I have a Windows 7 desktop at my office. There is a Dell MFP2335dn network printer installed on the dekstop. The printer worked fine for me (in that I could print from my desktop) some time back, but recently I have not been able to print. When I submit a print job, it stays in the queue for a long time and nothing gets printed. When I check the status of the printer in "Devices and Printers," it says "Offline."

I removed the printer installed on my desktop, and tried to install the drivers downloaded from Dell's website, but still get the same problem.

The printer is on, connected to network and ready. My computer can see the printer if I type its address — — in my browser. There I can see that its status is "Ready."

What do I have to do to print?


You have established that your printer is online, and can be connected to across the network and a web-browser. That's excellent.

The next step is making sure your Windows device for this printer is configured properly.

What you need to do is open the "Printer Properties" dialog for the printer in question (Start --> Devices and Printers --> right-click on printer, choose "Printer Properties")

Then, choose the Ports tab, and make sure that the port with the checkmark next to it, correctly represents the network address that your printer is at.

Rebooting and restarting your computer, printer and/or print-spooler, or upgrading the printer memory should not affect this setting (and if they do, I would start to question whether your printer was set to use DHCP, or had other even more arcane problems).

In case your network is using DHCP for printers, then it may make sense to set the port for your Windows 7 printer to a DNS name instead of an address, so that if/when it changes in the future, your computer will be able to resolve the name to an address.

  • This is good information but on an old question. – Jeremy W Apr 2 '12 at 16:42

Most networking printers have a webinterface where you can check status. Have you tried surf to it to check if it actually recieves your printjob? Else it might me the printerqueue that mess things up (this means that several users is likely to have the same problem). Do you have several computers that can try to print on the same printer (pref win 7 ones)? If the printer is part of your AD, you might want to try to remove it from there aswell as the driver from the printersharing service. Then re-add it.

  • @xeet: From my computer,I can see the printer if i type its address httP:// in my browser. There i can see that it's status is Ready. Also others can print to it. – goldenmean Aug 18 '10 at 16:30
  • When i try to install the printer using the Dell supplied driver installer, it asks gives me two options - MFP 2335dn and MFP 2335 dn PS, (Post script i guess). Which is the right one? – goldenmean Aug 18 '10 at 16:41
  • I tried setting both-MFP 2335dn PS and MFP 2335dn , as my default printers, after installing drivers for the same. Still no success. Could this be a printer driver issue on my PC.or Something network related on my PC. Because sure it has got to do with my PC. Others are able to use the printer ok. – goldenmean Aug 18 '10 at 16:55
  • According to your description its the first one, surf to your printer and make sure its the correct model. Do the others run windows 7 aswell? My experience is that many drivers arnt ready for windows 7 yet, vista drivers might help you here. Install wireshark to sniff the traffic, to see if the computer actually sends the job. Also, it is considered good practise to not put internal adresses on a website thats available to whe public. – xeet Aug 18 '10 at 16:56
  • One mroe thing i tried is restart the print spooler service in windows. After that the printer showed Status:Ready for a soem time. I tried giving a print to it. Still it did not print. Then after some time it again shows status:offline. Strange.. – goldenmean Aug 18 '10 at 17:14

I got a similar problem with HP printers at work. We solved it by adding Memory to the printers. I don´t really know how, but from time to time some printjobs just "hang" the printer up. It won´t print unless you power it off, wait a few seconds until the memory is empty caused by power loss and power it on again. I guess this has to do with the memory available. If the job is a little bigger than normal (i.e.: 250mb pdf file on printer with 128mb intern memory), it is possible your printer suspended.


Just a shot, but do a clean boot. Run nothing else. Turn off your firewall/antivirus suite and test. For some reason, my Brother refused to run correctly when I had Norton turned on despite putting all sorts of port exceptions. Turning off the firewall was the only way I could get to the printer.


You must install through the network installation, not in a regular installation.

It will search for itself. When you see your device, select it and click next.

Print a test to check if it installed correctly.

  • Can you provide a step-by-step? Installing printer drivers is seemingly simple but can be confusing for many. – Lizz Mar 26 '13 at 3:33

I have had the same problem for several months. I print from Windows 7 Pro to network printers. I would simultaneously lose access to all network printers and SOME USB local devices. After many hours of fiddling, I found the problem....for me. Norton WASN'T loaded. I loaded Norton and everything started working. All spooled jobs printed. Dunno why, but there it is.

Not the answer you're looking for? Browse other questions tagged or ask your own question.