1

Background

I am currently using a HP EliteBook 850 G7 laptop connected to a HP USB-C Essential Dock G5. This docking station currently has 3 USB peripherals connected including 2 monitors connected each with a DisplayPort cable.

My problem

My primary monitor (monitor 1, AOC C27G2ZU/BK) works just fine, but the secondary monitor (monitor 2, DELL U2412M) is not displaying anything. Both are detected by Windows (Windows 10 Version 10.0.19045 Build 19045) but there's no signal on the second one.

The monitor has worked on the same docking station for a few times earlier, but now it has not been working for several months.

When I am not using the laptop/docking station then I use both monitors directly connected to another desktop PC where both are working as expected.

What I've tried troubleshooting

I have tried multiple things in an attempt to solve this, this includes:

  • Updating all drivers to the latest version
  • Updating BIOS firmware
  • Updating HP graphics
  • Updating Windows
  • Configured BIOS
  • Configured display settings with different combinations
  • Unplugging, restarting (incl. with power button + F6 combination), etc.
  • Tried a different DisplayPort cable
  • Only connecting the second monitor and nothing else

At my workplace I use the HP USB-C Dock G5 and the only difference compared to the HP USB-C Essential Dock G5 is that:

  • HP USB-C Dock G5 supports Power to system: Up to 100W via USB-C Power to host (USB-C PD): 5V, 9V, 10V, 12V, 15V, 20V all at 5A MAX
  • HP USB-C Essential Dock G5 supports Power to host: Up to 65 W via USB Type-C (both HP and non-HP host devices)

Hypothesis

My hypothesis so far that there is either a compatibility issue or a -'lack of power'-issue with displaying a signal from the Essential Dock G5 to the DELL U2412M monitor because when I used the Dock G5 it worked just fine at all times.

This is based on:

  • the troubleshooting I've done
  • the fact that there are no drivers available that can be installed for the Essential Dock G5 (unlike Dock G5)
  • that this monitor has worked a few times on the same docking station previously and all the time on the Dock G5.

Do you guys have any suggestions for what I can do next? I wanted to post it here first before resorting to creating an user and posting the same question on the HP support forums.

0

You must log in to answer this question.