Low WiFi dbm on Windows and Linux, but new adapter doesn't fix the problem.

I recently brought my laptop into the shop to replace the power connection. When it came back, I ran the recommended updates in Ubuntu Software Updater. I also noticed the internet connection was slow.

I have an Intel 8260NGW wifi adapter.

  1. I ran iwconfig to verify signal strength (-79dbm next to eero 6 extender, dropping to -90 and disconnecting fifteen feet away without obstructions)
lo        no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"My network"  
          Mode:Managed  Frequency:5.765 GHz  Access Point: D0:16:7C:24:0F:83   
          Bit Rate=195.1 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=36/70  Signal level=-74 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:20  Invalid misc:2595   Missed beacon:0
  1. I ran lshw -c network to verify my driver (iwlwifi-5.19.0-38-generic, on Intel's page of linux drivers I think?).
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 3a
       serial: 34:f6:4b:61:a6:25
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.19.0-38-generic firmware=36.ca7b901d.0 8000C-36.ucode ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:140 memory:ed100000-ed101fff
  1. I then rebooted to Windows, checked the Wifi Analyzer app, and saw the same -79 dbm.
  2. I borrowed another Windows laptop, which reads -35 dbm next to the extender.
  3. Thinking it's gotta be that the tech damaged the adapter, I pop out the battery and swap out a new 8260NGW I got on Amazon. Signal strength is unchanged on Windows and Linux.

What else can I do? Will accept troubleshooting on Windows or Linux, but my main use is Linux.

  • 2
    If the problem didn't occur before and does now on both OSes it points to an hardware problem indeed. You got the correct idea but went overboard replacing the WiFi card (those typically either work or don't) because the symptom is not of a defective card but of something wrong with the antennae. Maybe one was disconnected during the repair or the main and aux were wrongly reconnected. Apr 10 at 2:25
  • Ah, thanks. I've seen in some pictures that the wifi adapter has lines running from the antenna connections, but mine doesn't have these. Does that mean it just uses an internal antenna? Apr 10 at 2:50
  • 7
    No, Bluetooth may use traces in the PCB as an antenna but that WiFi module must use external antennae (plural) that are embedded in the bezel and have two cables that connect to the terminals near the screw indentation (and marked as main and aux). As expected the shop didn't reconnect those or possibly did something worse. Apr 10 at 2:57
  • 6
    100% right. The antenna leads were tucked under the motherboard, out of sight, hence why I assumed mine didn't have them. iwconfig now shows -26dbm. If you want to post this as an answer I'll accept it. Thanks so much! Apr 10 at 3:48

1 Answer 1


The reported symptom indicates a problem with the hardware but not with the WiFi card itself, the replacement showed the same low signal problem.

It points out to incorrectly connected antennae terminals or not connected at all.

After close inspection the leads were found tucked under the motherboard. Reconnecting them solved the problem according to the comments:

iwconfig now shows -26dbm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .