-1

I'm fairly new to linux and was running Fedora 37. When the new release for Fedora 38 came out i decided to upgrade. After doing so DaVinci Resolve stopped working. It doesn't even launch, I just get a spinning ball like it's loading and then it quietly fails.

When trying to trying to launch it from opt/resolve/bin/resolve using the terminal I get the following: ./resolve: symbol lookup error: /lib64/libpango-1.0.so.0: undefined symbol: g_string_free_and_steal which after googling I was still unsure about.

I have attempted to completely uninstall it and reinstall with the same issue. If someone could explain either how to fix symbol lookup error or simply what went wrong I would appreciate it. Thanks

Edit: Someone asked if I was trying to run the latest version of davinci resolve, which is yes. I installed pando-devel as suggested but still the same story, launching it through terminal I get /opt/resolve/bin/resolve: symbol lookup error: /lib64/libpango-1.0.so.0: undefined symbol: g_string_free_and_steal

If more information is needed please let me know how I would go about gathering more information to dump here. Thanks

Also not sure if it's at all related or if it even matters but when I launch DaVinci_Resolve_Welcome (in /opt/resolve/Onbording/) it is just a black box which after some time says "Welcome to Davinci Resolve" is not responding and gives me the option to force quit or wait.

Was talking to someone on discord and they recommended this and it worked:

Go to /opt/resolve/libs, create a new folder (name it something like _disabled), then open the terminal in that folder and type mv libglib-2.0.so* _disabled/ . I haven't tested if it's stable after doing so but I did have it open in the background for a bit with no crashes.

6
  • Have you try to install pango development package. Do you install the last version of DaVinci Resolve? Commented Apr 21, 2023 at 16:54
  • Also have you consider using RHEL? Fedora is testbed for RedHat. Commented Apr 21, 2023 at 17:01
  • As above the package you should try to install is pango-devel. Do that then edit to update the question with the results. If this solves the problem then it can be turned into an answer. Commented Apr 21, 2023 at 17:23
  • You are trying to use proprietary software on a distribution it does not support.
    – Daniel B
    Commented Apr 21, 2023 at 20:30
  • About pango-devel such a package only impacts package we are trying to compile. No impact on a package we are trying to run. About the support of the software... if libpango is broken, this is not the responsability of DaVinci. We should either try to install a past version of libpango or compile a new fresh version of glib (from the Git source). Commented Apr 21, 2023 at 21:12

2 Answers 2

1

It does seem to be a known issue, shared with many users of the g_string_free_and_steal function (even on FreeBSD with the wellknown InkScape). https://forums.freebsd.org/threads/inkscape-undefined-symbol-g_string_free_and_steal-on-freebsd-13-2.88736/

The principle is simple: each package brings a bunch of functions. Other packages use them. And if a package stop to bring a function this will make other functions stop working. The opposite is true, if a software brings a function, it is consumed... but the new version of the consumers are released too soon, they will break if the provider is not released at the same time.

On https://raw.githubusercontent.com/GNOME/glib/master/NEWS I read:

  • Add g_string_free_and_steal() and use it to warn on unused results from g_string_free (_, FALSE) (!3219, !3226, work by Matthias Clasen and Sergey Bugaev)

From a fresh copy of the glib library, I can read the presence of a g_string_free_and_steal string.

Then this function seems to be new. Then it may be used, but the release of the consumer and the producer could have a bad schedule (the consumer first, the producer later).

Then I guess a later update will resolve such issue.

I guess this is a pitfall of rolling release like Fedora: some release may break because the developers have no enough feedback. Other distributions have multiple levels of maturity. Then with Debian such issues are seen an corrected in the testing version. And when all is ok, it this version is put as stable for 2 years (where only security patchs are admitted). OpenSuse has also a 2 modes schedule (Leap vs. Tumbleweed). Then we have to choose between a bleeding-edge distribution which breaks sometime and a stable (more boring) distribution. Among the RedHat family, Fedora and CentOS stream are ahead (less tested) than RedHat Enterprise Linux (RHEL). But if you don't want to pay for RedHat, AlmaLinux and RockyLinux are designed to be RedHat compatible (since RH is open source, they can copy it).

We can also point OpenSuse which integrates Btrfs snapshots quite well. Then if something get wrong, we can ask to reboot back when all was ok... but here, I can only invite you to 1/ use a backup, 2/ wait for the correction (the issue is not localised, I guess it will be resolved in a future release), 3/ dig further (recompile a later glib library from the source).

2
  • Ahhh, I see, I see. Thanks for the info, I appreciate it
    – Xeveo
    Commented Apr 21, 2023 at 20:55
  • 2 added words about AlmaLinux and RockyLinux which are in the same family than Fedora. Commented Apr 21, 2023 at 21:36
1

The version of Pango shipped by Fedora 38 requires Glib version 2.75.3 or newer. DaVinci Resolve ships an older version of Glib. A simple trick is to get rid of Glib shipped by DaVinci Resolve which will cause Pango to use the updated version of Glib shipped by Fedora 38.

sudo mkdir /opt/resolve/libs/_disabled
sudo mv /opt/resolve/libs/libglib-2.0.so* /opt/resolve/libs/_disabled

Assuming you have satisfied all other requirements (which probably includes installing mesa-libGLU and possibly includes mesa-libOpenCL for AMD graphics), you should be able to run DaVinci Resolve and DaVinci Resolve Studio.

1
  • Worked perfectly on ubuntu 22.10 and DaVinci resolve 18.6
    – time4tea
    Commented Jan 1 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .