I have a Linux Mint laptop computer with two graphics cards: one built-in to the Intel motherboard, and a separate Nvidia card. For a long time, I've just been using the Intel card, but recently I installed the Nvidia drivers to make a game work. Everything works perfectly with the new drivers ... except that Chrome takes a couple of minutes to start up.

Technically, it starts up immediately, as I can see the multiple windows I had opened previously in the task bar ... but they're invisible: I can't even see the window outline, let alone the webpage inside. After a couple of minutes of waiting, the contents finally show up, and I can use Chrome as normal.

At the command line when I start Chrome (with extensions disabled) I see:

$ google-chrome --disable-extensions

INFO: Created TensorFlow Lite XNNPACK delegate for CPU.

Then, when it finally starts working for real, I see:

MESA-INTEL: warning: Haswell Vulkan support is incomplete

I've tried the following:

  • Uninstalling and reinstalling Chrome

  • Disabling "Use hardware acceleration when available" in Chrome settings

  • Setting my screensaver to "Never" turn on

  • google-chrome --disable-gpu

  • google-chrome --use-gl=desktop

  • google-chrome --disable-gpu-driver-bug-workarounds

  • google-chrome --disable-features=UseChromeOSDirectVideoDecoder

  • google-chrome --enable-features=Vulkan

  • As per https://bbs.archlinux.org/viewtopic.php?id=236020 I tried making a /usr/share/dbus-1/services/org.freedesktop.Notifications.service file (and restarting my computer)

but none of those fixes have helped.

If anyone has any suggestions of anything else I can try, I'd appreciate any help whatsoever.

Further Details:

I have a GeForce GTX870M Card. When I use the Linux Mint Driver Manager it gives me options for nvidia-driver-470, nvidia-driver-390 and xserver-xorg-video-nouveau; there are no newer options.

When I install Cuda (the way @GChuf suggests in an answer below) I wind up with the 530 driver, which works poorly (eg. I can use two monitors, as I can with the other drivers).

Unfortunately, I can't install the driver @GChuf recommends (418.113), because it gives me an asm/kmap_types.h: No such file or directory error, which evidently means I don't have Cuda installed ... but I can't install Cuda without the 530 driver, and the 418 driver won't install with that driver installed.

  • Try running Chrome without extensions to see if it happens, so with --disable-extensions switch
    – Destroy666
    Apr 23 at 17:55
  • Great suggestion. I tried that, and it eliminated all the errors at the command line (so I guess it was an extension that was having issues with my screensaver?) ... but the fundamental problem, of Chrome not showing up for a couple minutes after I started it, remained :( Apr 23 at 18:53
  • An extension like Bitwarden comes to mind as it uses power functions to detect computer's inactivity, when it comes to the screensaver errors. For the slowness, did you try updating the driver?
    – Destroy666
    Apr 23 at 19:04
  • Not using Bitwarden, but it could be some other extension; I'm not concerned by the screensaver thing though, just the two minute startup time for Chrome itself. As for the driver, yes, I'm using the latest Nvidia driver available on the Linux Mint Driver Manager, nvidia-driver-470. When I try the 390 driver my system won't even start up, and the only other option is the Nouveau driver (which I was using, and it worked great ... except I couldn't use the Nvidia graphics card with it). Apr 23 at 19:20
  • Which GPU do you use, and which mint version? Nvidia driver 470 isn't exactly the latest, but maybr it's the latest supported for your GPU/OS.
    – GChuf
    Apr 29 at 21:18

1 Answer 1


I think the actual problem comes from the drivers, not from Chrome. Nvidia driver 470 might actually be "too new" for your GPU.

In my experience, installing drivers manually is always less problematic than installing drivers through driver managers.

I suggest you try this:

Nvidia Drivers Download Page

If this approach doesn't work, there's another option that you can try. This always seemed to work for me (on Ubuntu) - Download CUDA toolkit (if you don't mind extra couple of gigabytes of used space ...):

  • Go to https://developer.nvidia.com/cuda-toolkit-archive
  • Download Cuda 10.0 - which requires a minimum driver version of 410.48. Cuda 10.1 or 10.2 might also work for you.
  • Install the .dpkg file
  • The drivers will be installed together with the CUDA toolkit
  • I tried to install to install without Cuda and got error: asm/kmap_types.h: No such file or directory. I then tried installing Cuda (both the way you suggested and other ways). The other ways didn't work, and your's did, but ... it came with the Nvidia 530 drivers. I can't remove those drivers without removing Cuda, and if I try to install the 418.113 driver with the 530 drivers installed, it still fails (with that same error). May 3 at 17:33
  • Hm, so you have cuda 10.x with drivers v530? Regardless of driver version, does chrome start up any faster now that you have installed drivers together with cuda?
    – GChuf
    May 3 at 17:42
  • Chrome starts up better, but the driver has other issues (eg. I can't run a second monitor with the laptop; they just mirror each other ... and other programs work poorly). May 3 at 20:08
  • Hm, I'm out of ideas. Maybe installing an even older cuda version would help. Also, I think you didnt mention which mint version you are using. Is updating your OS a viable option?
    – GChuf
    May 6 at 17:32
  • Any idea how I could install an older cuda? Also I'm running Linux Mint 21.1, which is the newest. May 6 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .