Our USB mouse was stolen and a PS/2 OK_520 Mouse that works OK on my Medion PC, running Windows 7 32-bit, if plugged in before booting, is not recognised by Windows 7 64-bit on a Dell INSPIRONone_19T with a 19" Touch Screen. (It is a communal computer available to all residents.)

A USB mouse works OK and the Update Driver option reports: 'driver is up to date'.

Without the USB Mouse, Device Manager/Mice shows only the Touch Screen as a Mouse.

The Add New Hardware option searches but shows nothing and the Troubleshooter says ' device possibly not recognised, alterations made to system, try again.' but it is still not recognised after repeated re-boots.

The BIOS does not seem to have any option to enable a PS/2 Mouse.

The Mouse is very old so maybe it is not 64-bit compatible, or there is no 64-bit driver for one, but how to get one if the device is not recognised?

  • Are you sure the Dell's PS/2 port works? – Velociraptors Aug 19 '10 at 21:39
  • I got a more modern but still not optical and the Dell 64 bit Win7 recognised oit and it worked OK so the port is OK. – Bogan Aug 20 '10 at 15:27
  • Drivers are for PS2 port, not for the mouse – phuclv Oct 18 '15 at 1:23
  • Go to a store and buy a cheap mouse – Keltari Oct 1 '16 at 13:45

The mouse itself is likely 64-bit compatible. It's generally not a matter of OS bitness. Windows 7, x86 and x64, has PS/2 compatibility.

If it's a complicated mouse, it could be driver-related, but for a simple 2/3-button mouse, you shouldn't have a problem. Does the mouse come with drivers?

It's far more likely the motherboard, BIOS, or PS/2 mouse plug is the problem.

The motherboard may not be designed to handle PS/2 mice. If it has a PS/2 plug, you can generally assume it should, but... ya never know. ;)

I haven't seen a BIOS setting to enable/disable PS/2 devices, they tend to be something that's just on if it's there and are a very low-level interface (hence the support in older systems). You may look for settings that specify where the BIOS enables/loads input methods, there may be something there (mine has a PS/2 or USB-preferred setting, I think).

It's also possible the PS/2 plug is shot. It's rarer on modern mobos, but older ones were finicky about hot-swapping PS/2 devices.

Test the plug with a different PS/2 mouse, test the mouse on a different system, and check the manufacturer's websites (for the motherboard/laptop and mouse) for any incompatibility reports or (better yet) patches.

| improve this answer | |
  • After reading your note, I realised most of the re-boots were warm restarts.On full cold re-boot a small window opened saying Windows had detected a PS/2 device and installed driver, another window requred a re-start to effect the changes. Low and behold it worked. Unfortunately, the next morning, with nothing changed, it was no longer recognised and is still like that. Thanks for the prompt response, see comments below and above. – Bogan Aug 20 '10 at 15:47
  • 1
  • @Bogan On modern PCs, the BIOS is supposed to detect the precense of PS/2 devices at boot time and configure legacy resources so that, when the OS boots, the devices are available and usable to the OS. Based on your question and your follow-up comment, I suspect the issue is actually a faulty PS/2 BIOS implementation on Dell's part (assuming the mouse is actually OK and PS/2 compliant). I've had similar issues on modern HP PCs with certain PS/2 keyboards and the BIOS was to blame (confirmed by HP - but never fixed as not worth it). – misha256 Apr 21 '16 at 22:23

If there are no options in the BIOS relating to PS/2, the only thing I can advise is to check that the PS/2 socket on the pc is fully working.

If the touch-screen interface is USB or removable, you can try unplugging it and testing the mouse again (may be it gets disabled if something else is detected - but unlikely).

If all else fails, buy a new USB mouse!

| improve this answer | |
  • Socket is OK, Touch Screen is integral; the problem is now academic as a kind stranger donated not one but two USB Mice. Interestingly, The 64bit Dell shows the Touch Screen as an HID-Compliant Mouse,but the 32bit Medion separate Monitor Touch Screen is USB connected and Device Manager does not list it at all, though it works OK. Thanks anyway for replying so promptly. – Bogan Aug 20 '10 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.