I spent an enormous amount of time working on multiple sheets in a single Excel file. Now, it's gone and just has an old version. I'm not sure why it didn't get saved (I typically save things way more often than needed), but that's besides the point now.

  • I've tried a bunch of existing solutions for this on the internet, but I was hoping there'd be something more specific.

  • I'm on a Mac. Autosave was not on.

  • I am willing to do anything to get this data back, including Disk Drill-esque methods.

  • "Browse version history" is grayed out.

I'm asking this here because all of the solutions I've seen and tried are only doable on non-Mac computers. If there's any information I'm not remembering to include, I'm more than happy to give additional details.

Here is a list of things I've tried:

  • Checked trash and the time machine.
  • Checked temporary files: it looks like there's a newer temporary file instead that is too small in size to be my sheets. (New temporary files appear not to overwrite new ones in Excel 365, though.)
  • Tried the solutions here (I'm on version 16.61.1 of Excel and macOS Monterey 12.2.1, so these menus don't exist on my version.) Similarly, I don't appear to have the correct version to do this because I have Excel 365.
  • Attempted to find any "previous versions" by opening the properties/get info page of the file.
  • I searched for .tmp files in Finder, but didn't see any of those files.
  • I have installed EaseUS Data Recovery Wizard, and it is loading: I will try searching for .tmp files within it.
  • I've tried solutions like this that don't work on macOS and Excel 365.
  • I've tried finding "Unsaved Workbooks/Manage Workbook," which doesn't seem to exist on Excel 365.

Not much time has elapsed since the creation of the file I want to recover, I have barely used Excel since (just for troubleshooting), and I have 177 GB of unused storage on my computer.

There is a ~ar4014.xar XAR archive document here: "/Users/user/Library/Containers/com.microsoft.Excel/Data/Library/Application Support/Microsoft/~ar4014.xar". The file is 25 KB, which is about what's expected for the file I'm trying to recover. It has the correct number of sheets: there are files within the .xar that say "sheet2.bin", "binaryIndex3.bin", "sheet6.bin.rels", etc., so I hope the data exists there if I can figure out a way to extract it.

Changing the extension to .xlsx, which is suggested here, does not work as the file is grayed out and it says:

"Excel cannot open the file 'ar4014_2.xlsx' because the file format or file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."

The data is definitely in the .bin files within the .xar file: I can see the correct English text in the .bin when I converted .bin to ASCII.

  • Please don't cross-post to multiple SE sites. Pick one & stick to it, or flag for migration. Is cross-posting a question on multiple Stack Exchange sites permitted if the question is on-topic for each site? - apple.stackexchange.com/questions/459225/…
    – Tetsujin
    Apr 28 at 11:52
  • Got it, thanks; I didn't know. Do you know which site would be better for this question? (I'm guessing this one because it's closed on the other site.)
    – BigMistake
    Apr 28 at 11:53
  • You were not synchronizing the file to the cloud based on your description. What this means is the file you want to restore does not exist. I am going to assume you didn't have the Time Machine enabled, or more specifically, the file wasn't being backed up. The article on .tmp files only applies to Windows, specifically Office 2010, which of course does NOT exist on macOS.
    – Ramhound
    Apr 28 at 11:54
  • Yes, there's no cloud backup. However, I believe the data itself should still exist on the drive if it hasn't been overwritten. I think Excel 365 on macOS also uses temp files, referred to by the prefix "~$".
    – BigMistake
    Apr 28 at 11:55
  • @BigMistake - If we are talking about an SSD. Data Recovery from file fragments is extremely difficult. SSDs handle data differently; while a mechanical HDD allows you to view every sector on the disk, an SSD internally determines where a file should exist or not exist. Once the file was overwritten, it's very likely the original data was replaced or is now inaccessible on cells marked internally as overwritten. BLUF: It appears you were using none of the features to save and back up the file automatically.
    – Ramhound
    Apr 28 at 11:56

1 Answer 1



  • Navigate to "/Users/user/Library/Containers/com.microsoft.Excel/Data/Library/Application Support/Microsoft/"

  • Look for a file with two letters followed by four numbers (e.g., ~ar4014.xar) that's around the size of your file and has a corresponding creation/modified date

  • Copy the file (e.g., ~ar4014.xar) to a new location

  • Change the file extension to .xls (not .xlsx) and delete the "~" character

  • Control click to open the file, then select open on the dialogue "The file format and extension of 'ar4014 2.xls' don't match. The file could be corrupted or unsafe. Unless you trust its source, don't open it. Do you want to open it anyway?"

  • This should open your original file in Excel!

  • This comment isn't directed at the author, I suspect the name of the .xar file, will depend on the original name of the Excel file.
    – Ramhound
    Apr 28 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .