My fully-updated Windows 11 Pro system keeps turning itself off or going into sleep or hibernation mode. I'm not technically sure which because I'm not a regular Windows user.

It is a virtually fresh factory install of Windows 11 that came with the Beelink SEI mini desktop with Intel Corei5-1235U Processor and 32GB of RAM system.

I'm running a hyper-V instance and need the VM to stay available 24/7 while there is otherwise no activity on the system. Every morning I wake up and the power light is off on the Beelink. When I touch the keyboard, the machine will "wake-up" and the VM will seem to resume operation for a while (a few minutes) until it crashes. I assume it's crashing because the underlying Windows 11 OS went to sleep. The other problem is that it's sleeping when I'm actively accessing the VM from another machine.

I've tried everything I can find online to set the power settings to NEVER sleep or hibernate.

I guess it's sleeping because when I switch to it and click the mouse, it will "wake up" and try to put the virtual machine back to its previous state.

However, if I'm actively using it with keystrokes and mouse movement it will not sleep. I currently have a mouse jiggler on the system to keep it alive and available.

I have configured the power settings to NEVER sleep as you can see in the screenshot:

enter image description here

I'm not normally a Windows user if that helps to indicate my knowledge level here.

  • Two things: Try Balanced Power Plan. Second update BIOS and all other drivers.
    – John
    May 3 at 22:18

2 Answers 2


Check the advanced power settings: Even though you have set the power settings to "Never" sleep, there may be other advanced power settings that are overriding this setting.

To access the advanced power settings, go to the Power Options in the Control Panel, and click on "Change plan settings" for your selected power plan. Then click on "Change advanced power settings" and check all the options in the list to ensure that they are also set to "Never", that means; Double check if all the sub-options from "Sleep" are set to "Never".

EDIT: I just saw, that you didn't choose "Never" at "When plugged in turn off my screen after". Just choose "Never" and turn off the monitor by pushing the power-button of itself.

  • If you cannot fix it in Windows itself, try a third-party app such as SoftwareOK's Don't Sleep, softwareok.com/?seite=Microsoft/DontSleep , or Zhorn's Caffeine, zhornsoftware.co.uk/caffeine May 3 at 22:16
  • It still happens if I use "Never" as the screen setting as well. May 3 at 23:22
  • With a few caveats, this is in fact an effective answer. Those caveats are: There wasn't a "Change advanced power settings" option, but there was a "Edit Power Plan" option when searching for "Power" in Control Panel. That looked similar to the System->Power panel but included an additional link at the bottom: "Change Advanced Power Settings". That link opened the Power Options panel, in which I found an additional setting "Hibernate After", which was set to several hours. I changed that to "Never" and we will see if that works. If it does, I'll mark this answer as correct. May 3 at 23:48
  • @I'mRootJames hibernation definitely doesn't work the way you described and doesn't wake up with mouse movement. I don't think your machine is even sleeping. You need to describe your issue more accurately. Do you want the screen to stop turning off? Does it do it too early? I'm not sure I understand.
    – Destroy666
    May 4 at 0:57
  • 1
    It was the hibernate setting that was only visible from the Control Panel -> Change Advanced Power Settings panel. May 4 at 3:58

Control Panel>Hardware and Sound>Power Options>Edit Plan Settings>Change advanced power settings>Sleep>Hibernate after>Plugged in: manually enter a very large number in the millions

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .