I have installed the program "VMS" needed to configure the IP camera. When I run shortcut, program does not reacting at all. But after several attempts to run, an error appears.

Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.

VMS.exe is the program for setup/viewing IP cameras (Video Surveillance). This program was provided to me by the seller. And it works perfectly in safe mode on my Windows 10 Pro x64. Also, I tried installing it on VirtualBox to Win 7 x32, works well too.

So I think the problem is only with my main system. I turned off Defender (added an exception for the file and directory), add all permission, try compatibility, but nothing helped.

Look like something block this program or some bad with a registry but I don't know what and how to check/fix.

I tried to completely remove the program from the computer and clean the registry and reinstall it.

I also manually searched the registry at the request of "VMS" and manually deleted everything that referred to VMS.exe

Also since the error refers to "access" I tried setting the properties/security/permissions for all users and on all points but that doesn't help either.

I've also tried running in compatibility mode and troubleshooter.

I would be grateful for any advice that can fix this error.

  • Your successive attempts are colliding with each other, that's all. Try #N+1 cannot open some device if try #N is still using it. Wait longer between attempts, or use Task Manager to make sure the previous attempt fully exited.
    – Ben Voigt
    May 4 at 20:55
  • @BenVoigt I understand what you mean. I just looked in the Task Manager, the new task does not appear at all. I also looked through Process Explorer program, sorted by startup time, and tried to run. Nothing appears in the processes.
    – Russell
    May 4 at 21:08
  • Check Windows Event Log for application errors. Run Process Monitor (made by same division of Microsoft as Process Explorer) and check what errors there are.
    – Ben Voigt
    May 4 at 21:23
  • @BenVoigt I used Process Monitor and filtered by Process Name "VMS.exe" and then run the program, and this show me 10 rows. 9 of these have the result column "Success", except one that has "NAME NOT FOUND" Operation: "RegQueryValue" Event class: Registry. Does that tell you anything? How can I share with you more information, like screenshots, etc? Event Viewer does not show anything while the program is running.
    – Russell
    May 4 at 22:44
  • @BenVoigt I was in a hurry. When I ran it again after a while, I got a much larger list of 772 events with statuses: "SUCCESS", "NAME NOT FOUND", "BUFFER TOO SMALL", "FILE LOCKED WITH ONLY READERS", "REPARSE", "NO MORE ENTRIES".
    – Russell
    May 4 at 22:57

1 Answer 1


So I fixed it! It was some other program/process that run with Windows startup and conflicted with VMS. I turned off all, restart and step-by-step run programs from the list, and with one of them VMS wouldn't start ("FixCamera.exe" I think it was installed a long time ago with web camera), so I deleted it, and now all work perfect. That's how I fixed it. Hope it will help someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .