5

On a recent windows 10 update this Microsoft Edge tray icon appeared:

[Tray icon

Clicking it opens this search bar that says "Search the web or type a URL":

Search bar

Windows 10 forums suggest disabling the auto-launch setting. I did this but then a month later (and presumably after another update) this setting was ignored and the tray icon and search bar came back.

Does anyone know how to permanently disable it?

1 Answer 1

10

My own solution:

Disable it

A. Registry

  1. Start menu > type "registry" > right click > run Registry Editor as admin (or open it if you don't have this option)

  2. In the input field at the top, under the menu bar, paste this:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge

  3. Do this twice: Right click > New > DWORD (32 bit value).

    Now: right click > rename each to:

    WebWidgetIsEnabledOnStartup

    WebWidgetAllowed

  4. Make sure each DWORD's value is 0 (it should be by default)

B. Double kill: Group policy

  1. Download the file MicrosoftEdgePolicyTemplates.cab at the edge enterprise page and extract the contents. This is the direct link I got (may not still work).

  2. Extract the cab and then the zip and find the folder admx. It should be at (extract folder)\MicrosoftEdgePolicyTemplates\windows\admx\

  3. Copy all the .admx files to C:\Windows\PolicyDefinitions. Then back in the admx folder find your language folder (e.g. en-US). Copy all the .adml files there to the corresponding language folder at PolicyDefinitions

  4. Start menu > type: gpedit.msc > open as admin (or just open).

  5. Click: Computer Configuration > Administrative Templates > All settings. Then (menu bar) View > Filter options > Filter for word(s) > input WebWidgetAllowed

  6. Filter. Microsoft Edge > Disable the setting for Computer and User

Source

2
  • note: downvotes on Stack Exchange are not to be mean to people. see /help/why-vote.
    – starball
    Commented May 8, 2023 at 3:01
  • Please note that both these registry keys are now deprecated according to Microsoft: learn.microsoft.com/en-us/deployedge/microsoft-edge-policies The only workaround I know is to have a process that launches on login that monitors for all instances of msedge.exe and kills them. It's amazing how they have reverted to the nonsense of Internet Explorer after adopting chromium for edge. Commented Jan 2 at 2:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .