I am trying to install Ubuntu 10.04 in a 16GB Verbatim USB flash drive so I can boot my computer from the usb and have a full ubuntu running (I also need an encrypted home folder). I just want to run it on one computer, not many, so I don't need LiveUSB features.
Partitioning the laptop's HD is not an option. Since I want a full installation, not a LiveUSB, solutions like UnetBootBin are also not an option.

The elements I have:

  • My laptop, an Acer 3810T with Windows 7 on it and a 320GB HD. USB booting is enabled in the Bios.
  • A 4GB Verbatim USB flash drive where I have Ubuntu 10.04 Live instalation, done using Universal-USB-Installer-v1.7.9
  • The 16GB Verbatim USB flash drive where I want a full installation of Ubuntu

What I have tried:

  1. I tried physically unplugging the internal HD and installing Ubuntu on the 16GB flash from a runing ubuntu in the 4GB one. The consequences are that the sytem works, as long as the internal HD is not connected again. Updating grub while running the Ubuntu in the 16GB and the internal HD connected had no effect.
  2. I tried to follow the GUI install of ubuntu from the 4GB flash. What happened is that grub was installed on the 16GB flash and windows 7 wouldn't load if the usb was not connected.

Any help will be welcomed cause this is sucking the life out of me.


Hm... the same method worked fine for me... I'll document what I did step by step, so you can check what you did differently.

  1. I booted up from a LiveCD (though this shouldn't make any difference) and chose the try option on boot.
  2. I went into the Installation wizard (Ubiquity) and clicked through the Language, Keyboard, and Time Zone prompts.
  3. At the partitioning prompt, I chose to specify the partitions manually, and clicked next.
  4. I partitioned the entire install drive into a big / partition. (Swap is a very bad idea for USB drives, so I didn't make one.)
  5. I clicked through and filled out the password prompts.
  6. At the sanity check prompt, I clicked Advanced... and then I set GRUB to install to /dev/sdb, which was the drive. I didn't set it to /dev/sdb1.
  7. I installed.

Did you do anything differently?

  • 1
    +1 for mentioning the problem with Swap on USB drives – Mistiry Aug 20 '10 at 16:07
  • Did you boot from the Live CD with an internal drive connected or without? I am going to try without in the meanwhile. – Jaime Aug 20 '10 at 16:57
  • I had an internal drive with Vista on it. – digitxp Aug 20 '10 at 17:25
  • OK, I will try with the internal drive inside later on and I'll post the results, it's friday night after all. :) Thanks for the help. – Jaime Aug 20 '10 at 17:30
  • @Jaime No problema. – digitxp Aug 20 '10 at 20:30

Did you enable USB booting and then re-prioritize the drive order of boot? (One can only hope its that simple, i have dealt with GRUB nightmares before too)

If so the machine should recognize the USB as containing a bootable partition and just use that. (Encrypting your home folder is a different matter)

If you think the install went went wrong, step six of @digi 's post is what i would assume to be the problem

  • Yes, all USB drives are prioritized. – Jaime Aug 20 '10 at 16:57

Good news everyone! Problem solved.

After asking a colleague and checking more info with "dmesg" we found the intricate solution to the problem:

"The USB flash drive have to be properly inserted on the USB slot, if it doesn't make contact it will not work." Indeed!

Which, with the very thin Verbatim drive means sticking it deep inside (no pun intended).

Sorry for taking your time with this, and thanks for the help provided.

  • By the way, despite the 16GB Verbatim USB flash drive is very thin, and light it has a major flaw. It does not make proper connection and it might disconnect itself after using it for some time. My advice, do not buy it. – Jaime Aug 24 '10 at 6:15
  • It also helps to do Ctrl+Alt+Del to reboot once the USB is in, in case you cannot go pass the BIOS – Jaime Sep 15 '10 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.