My ISP blocks many different websites. To bypass this I use a VPN service. The VPN service works perfectly on other Linux distributions that I have tried like Ubuntu and openSUSE however it does not bypass content blocking on Fedora.

It's quite baffling since on Fedora it connects successfully and it changes my location as well. I have tested this by looking up my IP address before and after connecting to the VPN server as well as opening up google's home page to see the country's name showing up in the bottom left corner of the page changing. Despite connecting to a different country my local ISP's content blocking is still present on Fedora. I emphasize again that this only happens using Fedora. I need to add that I have tested the other Linux distributions on the exact same machine as Fedora and on the exact same Internet connection. So the conditions are the same and the problem has nothing to do with my laptop or router.

The only thing I can think of is that Fedora has a peculiar network or firewall configuration by default but I don't know how to find out where exactly the problem is originating from.

  • Maybe it's still using ISPs DNS?
    – Daniel B
    May 13 at 14:58
  • Could you show the output of resolvectl while the VPN is connected? (What VPN software are you using?) May 13 at 18:31
  • resolvectl while connected to the VPN and while not connected to the VPN gave which is for Cloudflare. I am almost certain that the issue is not the VPN service because I had it work on a Windows machine, on two Android phones, an iPhone and as I mentioned earlier on Ubuntu and openSUSE. It just doesn't work on Fedora which tells me that most likely the default configuration on Fedora has something to do with it.
    – Paris
    May 13 at 19:51
  • Initially I tried it on the default GNOME version of Fedora 38 but after it failed I thought maybe there's a bug in that particular version. So I tried it on Fedora 37 and Fedora 38 KDE version. They all had the same result.
    – Paris
    May 13 at 20:03
  • that's not what I was asking about; resolvectl gives a lot more output than just "" and it's specifically the rest of it that I wanted to see May 13 at 20:35

1 Answer 1


Your DNS may be leaking. Perform an extended test from DNS leak test. Your ISP's DNS servers shouldn't be in the list.

Also, try to use DNS over HTTPS with Cloudlfare in Firefox to see if it solves your problem. It's under Settings > General > Network Settings.

If you think problem is the firewall, you can temporarily stop it: sudo systemctl stop firewalld

  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 13 at 15:52
  • I tried the DNS leak test and it listed a bunch of Cloudflare IP addresses but not my ISP's IP address. It also listed more Cloudflare IP addresses for the extended test. Also checking the DNS over HTTPS setting in Firefox had the same result as before.
    – Paris
    May 13 at 19:57
  • I was hoping disabling firewall would make a difference but unfortunately sudo systemctl stop firewalld.service did not solve the problem.
    – Paris
    May 14 at 9:07
  • @Paris Which VPN protocol does the app use? OpenVPN, WireGuard or else? You can try connecting with configuration file (if VPN provider gives) by VPN protocol's native client. VPN provider's app might have a specific problem with Fedora.
    – ceoonum
    May 14 at 12:07
  • It's a binary that I need to run via terminal using sudo so it's not a OpenVPN or a WireGuard profile. This is a thoughtful suggestion but the problem with OpenVPN is that it's easily detectable. My ISP uses deep packet inspection to figure out if the connection is a regular connection or a VPN connection and if the VPN service does not have some sort of obfuscation integrated into its protocol then it simply does not work. This is not a guess I am sure about this and I have tried many different OpenVPN based services in the past. They used to work prior to DPI technology being implemented.
    – Paris
    May 14 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .