9

I have LaiShiXiong-zm015.mp3 and LaiShiXiong-zm015.srt. The latter is the real subtitle for that mp3 audio.

When playing the mp3 audio with VLC 3.0.4, VLC shows that it has recognized my subtitle as "Track 1", but, the subtitle is not at all displayed on VLC's window.

Of course, when playing an mp4 video file, the corresponding subtitle is displayed correctly on my computer.

What's wrong with this? Could anyone help?

enter image description here

2
  • You can search for karaoke plugin(s)/support Commented May 16, 2023 at 7:11
  • Is it feasible to convert MP3 to video? Commented May 16, 2023 at 7:16

1 Answer 1

10

Play the MP3 file in VLC then go to Audio > Visualizations > Spectrometer. Now the subtitles should display. The info was taken from here. I've tested this out with a .srt file on VLC 3.0.18 Vetinari (latest at the moment) on Windows 10 and it works.

You can also use Musixmatch and MiniLyrics, according to this first post.

Edit: enter image description here

Edit 1:

I put together an AutoHotkey script for Windows that draws a black rectangle over VLC when the VLC window is active and it hides the rectangle when the VLC window is not active:

#SingleInstance, Force
#NoEnv
SetWorkingDir %A_ScriptDir%

Gui +AlwaysOnTop +Owner -Caption +ToolWindow
xpos := 0
ypos := 0
width := 700
height := 500
Gui, Show, X%xpos% Y%ypos% W%width% H%height% Hide, newtest


loop {
    if !WinExist("ahk_exe vlc.exe")
        Gui, Hide
    if WinActive("newtest ahk_class AutoHotkeyGUI")
        continue
    if WinActive("ahk_exe vlc.exe")
        Gui, Show, NoActivate
    if !WinActive("ahk_exe vlc.exe") && !WinActive("newtest ahk_class AutoHotkeyGUI") {
        Sleep, 100
        if !WinActive("ahk_exe vlc.exe") && !WinActive("newtest ahk_class AutoHotkeyGUI")
            Gui, Hide
    }
}
return

GuiClose:
ExitApp

This is what it looks like:enter image description here

The script is based on this code made by boiler.

Play around with the values of xpos, ypos, width and height to position the rectangle wherever you want.

This was tested out with AutoHotkey Version 1.1.34.04 on W10 x64.

Edit 3:

You can change this line:

Gui +AlwaysOnTop +Owner -Caption +ToolWindow

with this line:

Gui +Resize +AlwaysOnTop +Owner +Caption +ToolWindow

if you want to make the window resizable and draggable, but it would then look like this: enter image description here

5
  • 1
    Could you post a screenshot along side with your answer? -- Showing that the subtitle text is really displayed on VLC UI.
    – Jimm Chen
    Commented May 16, 2023 at 13:46
  • I have just added it.
    – rd51
    Commented May 16, 2023 at 14:03
  • 2
    Great, thank you. It would be better if there is way to dismiss the Spectrometer animation(only subtitles are required) , bcz sometimes it feels noisy.
    – Jimm Chen
    Commented May 16, 2023 at 17:48
  • 1
    You're welcome! :) Yeah, that is bothering while looking at the subtitles, and there seems no way to turn them off unless visualizations get disabled. What you can do next is ask on the VLC forum if they could implement a way to disable the animation for any of the visualizations that allow subtitles (not all of them do). Or, since projectM visualization shows subtitles, you can go here and ask them where to modify the code to be able to stop the animations, but still make the subtitles work with VLC.
    – rd51
    Commented May 16, 2023 at 18:36
  • I have updated my accepted answer with a more appropriate solution.
    – rd51
    Commented May 17, 2023 at 9:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .