When I type in http://example/ firefox rewites the url to http://www.example.com/. Is there any way to fix this behavior without recompiling firefox? I suspect something in about:config will help, but I am not sure what, and I'm somewhat leery of randomly changing things just to see if they have the effect I want.


What I would like is for firefox to try to make a http request to example (which it does, usually finding the address my etc/hosts file provides) and then, if unable to connect, to fail with a "could not connect" error, with example still in the address bar. Its current behavior is to then try to look up www.example.com, which tends to result in a 'valid' site, and I get a screen full of some domain squatter's dross and have to remove the www. and .com from the address before I can fix my typo.

  • So what is the effect you want?
    – John T
    Aug 20 '10 at 23:46
  • I'm able to get firefox to give me an error, mind posting your hosts file?
    – John T
    Aug 21 '10 at 0:07
  • Mozilla calls this "domain guessing", so perhaps someone with sufficient reputation (or the OP) could add that tag.
    – Reid
    Aug 21 '10 at 0:14
  • @JohnT, check browser.fixup.*? that seems to be the right place for me.
    – David X
    Aug 21 '10 at 0:25

I believe you want to set browser.fixup.alternate.enabled and perhaps keyword.enabled to false. See also this article and the about:config docs.

(Note: untested.)

  • browser.fixup.* = false or "" did it, thanks
    – David X
    Aug 21 '10 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.