I have a Nvidia Tesla P40 GPU set up on my Windows 11 machine, and I'm using it through WSL2 for applications that need its CUDA capabilities. These applications are running in various CUDA toolkit versions within Conda environments. To achieve this, I have to operate the P40 in WDDM mode since WSL2 can't recognize the GPU when it's in TCC mode.

While in WDDM mode, the P40 appears to have a virtual VGA port attached to a virtual display. In certain scenarios, Windows defaults to using this virtual display as the main one, ignoring the actual display connected to another graphics card in my system.

Is there a way to convince Windows that nothing is connected to the virtual VGA on the P40? Could I possibly modify a registry entry to make this change? I'd appreciate any help on this matter.

1 Answer 1


In the Registry Editor, navigate to the following key:


Expand the "Configuration" key to see its subkeys. Look for the subkey that corresponds to your Nvidia P40 GPU. The subkeys will be named with a combination of numbers and letters.

Within the subkey corresponding to your Nvidia P40 GPU, you should see a series of subkeys labeled "00", "01", "02", and so on. These subkeys represent the connected displays.

Look for the subkey that contains the settings for the virtual VGA port. It may have a name like "SIMULATED_...._...._00000000".

Right-click on the subkey for the virtual VGA port and select "Delete" to remove it. Confirm the deletion when prompted. Close the Registry Editor. Restart your computer for the changes to take effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .