I recently updated my Lenovo Desktop PC 90G9 to Windows 10 22H2 (before it had 1909). It was urgently necessary. After downloading this update and restarting the PC, Windows told me that the update had failed. Even after several new attempts, it was always the same.

Without further ado, I took the HDD out of the PC, booted it into my main computer and carried out the update there. This actually worked.

After I had removed the HDD from the PC again and installed it in the new PC, the Lenovo could no longer be started. Well, actually it did, but there was a boot loop. Windows tried to start the automatic repair during every boot, but it didn't work.

Automatische Reparatur

I thought that a clean install would help, but unfortunately in vain.

The boot loop just described remains. Even if I carry out the installation on my main computer and then reinstall the HDD in the Lenovo, the boot loop remains.

I have already activated "CSM" and deactivated "Secure Boot", unfortunately in vain.

I saw that there was someone experiencing the same problem with the exact same model... https://www.tenforums.com/installation-upgrade/189989-unable-rebuild-lenovo-desktop-90g9-4.html

But i didn't find any helpfull informations. What else can I do?

  • CSM should not be activated, and Secure Boot should be activated. Try to follow this procedure.
    – harrymc
    Jun 2 at 16:33
  • @harrymc That's the problem; I can't even get the ESD-Stick/Windows 10 Installation Medium to boot... There is the same problem as with the HDD: Boot-Screen (Lenovo label appears) and then the windows-logo but then it shuts down and tries to boot again, but it doesn't work and again and again... Jun 2 at 18:32
  • @PeterAndres - If you booted to an installation media and performed a clean install you had to change the boot order to do that, which means, performing that install would have updated the NVRAM on your device.
    – Ramhound
    Jun 2 at 19:00
  • Try to upgrade the BIOS to the latest version (seems to be here). Even if this version is already installed, the new installation will reinitialize stuff.
    – harrymc
    Jun 2 at 19:14
  • @Ramhound I think you don't understand: It tries to boot the ESD-Media/Windows 10 Stick but it's stuck in a boot loop. I already changed the boot order. Jun 2 at 19:19

1 Answer 1


I found a solution...

I had this problem for months now.

Just download the iso-file of the windows 10 version 1909 and install it via rufus onto a min 8GB-Stick. (Here you can download the iso-file: https://archive.org/details/win-10-1909-english-x-64) Then install windows with this stick in a normal maneer.

Once you've installed windows (wich should with this stick work fine), download a bios-update exe-file from the official lenovo website: https://support.lenovo.com/de/de/downloads/ds503426-bios-for-windows-10-64-bit-ideacentre-310s-08asr

Just run the exe file and answer all querys with "no" except the "would you like to continue with bios-update" (or something like that). Once the bios update is completed, you can continue in windows and try to download the update-assistant for windows 10 version 22h2: https://www.microsoft.com/de-de/software-download/windows10

run the update assistant, proceed the update like you would do at any other computer.

...aaaaannndddd; there you go. You have installed Windows 10 22h2 and can work with the desktop-machine again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .