0

I have Fedora 38 and I want to install protonVPN. I followed the guide and downloaded the respective rpm package but when I try to install it or update dnf I receive this error: [CODE]ProtonVPN Fedora Stable repository 0.0 B/s | 0 B 00:00
Errors during downloading metadata for repository 'protonvpn-fedora-stable':

  • Curl error (60): SSL peer certificate or SSH remote key was not OK for https://repo.protonvpn.com/fedora-38-stable/repodata/repomd.xml [SSL certificate problem: self-signed certificate in certificate chain] Error: Failed to download metadata for repo 'protonvpn-fedora-stable': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried Ignoring repositories: protonvpn-fedora-stable Last metadata expiration check: 2:45:09 ago on Mon 05 Jun 2023 05:35:41 PM EDT. Dependencies resolved. Nothing to do. Complete! [main@fedora Downloads]$ [/CODE] [B][CENTER]

"The error message you're receiving indicates a problem with the SSL certificate for the ProtonVPN repository. More specifically, the error "SSL certificate problem: self-signed certificate in certificate chain" suggests that there's a self-signed certificate somewhere in the certificate chain, which is generally considered insecure and can't be verified.

Here are a few possible solutions:

  1. Verify Your System Time: An incorrect system time can cause SSL errors. Check to make sure your system time is accurate.

  2. Try Disabling SSL Verification Temporarily: This isn't recommended for long-term solutions because it can leave your system vulnerable. But, for a quick fix or to see if SSL verification is the issue, you can try this. You'll need to modify your DNF configuration file to disable SSL verification. Here's how:

    Open the DNF configuration file in a text editor with root permissions. For example, you can use sudo with nano like this:

    sudo nano /etc/dnf/dnf.conf
    

    Then, add or modify the sslverify line to be False:

    sslverify=False
    

    Save and exit the file. Then try running sudo dnf update again.

    Remember to set sslverify back to True once you're done to keep your system secure.

  3. Contact ProtonVPN Support: If none of the above solutions work, there might be an issue with the repository or the certificate that ProtonVPN needs to fix. Reach out to their support for help.

Remember, solution 2 is not recommended for long-term use as it disables SSL verification, which can leave your system vulnerable. It's primarily a troubleshooting step to help determine where the issue is coming from."[/CENTER][/B]

How can I address this?

0

You must log in to answer this question.

Browse other questions tagged .