3

I have a new PC that I was very excited about until I realized that it consistently refuses to enter sleep mode. More precisely, it wakes up immediately after being put to sleep. This is very frustrating, and I'm looking for a solution to this problem.

I searched online and found that it's often the network card, keyboard, or mouse that unintentionally wake up the PC from sleep mode. I disabled the ability for these devices to interfere with sleep mode, but it didn't work. I still can't keep the PC in sleep mode for more than a second.

Then I came across this command to run in CMD: powercfg -lastwake This command tells you which device is causing the wake-up event. To my surprise, I found the following information:

Wake History Count - 1
Wake History [0]
Wake Source Count - 1
Wake Source [0]
Type: Device
Instance Path: [I can give you the path if you need it]
Friendly Name:
Description: PCI Express Root Port
Manufacturer: (Standard system devices)

So now I know that a PCI Express Port is directly waking up my PC from sleep mode, but I'm still unable to do anything to prevent it.

I tried changing the graphics card slot, but the problem remains the same.

I'm really stuck, could someone please help me out?

Edit :

Windows 11
Cpu : AMD Ryzen 7 7700X
GPU : Zotac Gaming GeForce RTX 3060 Ti
Mother Board : ASUS PRIME X670-P
4
  • You do not say what kind of PC. What I do with commercial PCs is make sure BIOS (UEFI) and Drivers are all up to date. Look in BIOS settings for any Wake On .... settings.
    – anon
    Commented Jun 11, 2023 at 13:16
  • 1
    @John I’ve updated my question to add my CPU, GPU and Motherboard
    – Mickaël
    Commented Jun 11, 2023 at 16:02
  • Read over comments on this post and then see if you can reverse engineer that a bit to make it not allow waking up from sleep, etc. as the various comments in this thread talk about just in case: reddit.com/r/nvidia/comments/52cr0b/…. Looks for card level control settings per firmware on it too interfacing with Windows. Check for Nvidia control interface, drivers updates and BIOS firmware updates might be useful too both computer and GPU both. Commented Jun 11, 2023 at 16:46
  • Unfortunately nothing of this helped, but thanks a lot anyway
    – Mickaël
    Commented Jun 13, 2023 at 16:51

1 Answer 1

2

I have found the solution to my problem, and I will describe it here as it could help others who encounter the same issue.

Step 1: Launch a command prompt as an administrator and enter the following command:

powercfg -lastwake

This command will provide you with the last device that woke up your computer from sleep mode. In your case it's "PCI Express Root Port"

Step 2 : Write this command:

powercfg -devicedisablewake "PCI Express Root Port"

This command is supposed to solve the issue, but it might not work because of windows preventing users to manage some settings.

If Step 2 didn't Work, Step 3 : Open PowerShell as Administrator and write this command :

powershell -command "Start-Process powercfg -ArgumentList '-devicedisablewake', '""PCI Express Root Port""' -Verb RunAs"

And it should solve the issue, at least it solved mine !

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .