5

I just installed ubuntu, during installation I chose the side by side option so I will have windows and ubuntu installed on the same computer. But now every time I turn on the computer it boots into Ubuntu by default. I thought there would be a screen with options of which OS to load but there isn't.

I know windows didn't get erased or anything because in Ubuntu when I click on the hard drive I can see all window system and personal files in there. So what is the matter? How can I get the option of which OS to load at boot?

P.S. this is my 1st time trying linux and I'm not even that sure about how installing programs on linux works.

4
  • Installing programs on Ubuntu is easy: they are all collected on special servers (called repositories) and you can install them by marking a checkbox in the Ubuntu Software Center application.
    – JanC
    Commented Aug 22, 2010 at 7:55
  • 1
    This site is a perfectly fine place to ask your question. But you have a better chance at getting more focused help (e.g. with screenshots for Ubuntu instead of more generic command line manipulations) by asking on the Ubuntu-specific Stack Exchange site. Commented Aug 22, 2010 at 9:47
  • Hey Jake, check out VirtualBox. It makes trying different operating systems very easy. virtualbox.org Commented Aug 22, 2010 at 14:28
  • Could you run the following command from a Terminal in Ubuntu and see if it lists Windows? sudo update-grub
    – Bobby
    Commented Aug 23, 2010 at 11:47

5 Answers 5

5

The normal situation when you install Ubuntu after installing Windows (and keep the Windows installation) is that Ubuntu takes responsibility for booting the machine. Before Linux proper loads, you should see a menu (shown by the bootloader, which is called Grub) where you can select whether to boot into Ubuntu or Windows.

If you don't see this menu, it means the installation didn't do what it should have. Try pressing Shift a little after your computer starts, before the BIOS finishes initializing. This will show the menu.

Within Ubuntu, you can configure the bootloader by editing /etc/default/grub. The settings are documented on the Ubuntu website. Back up the original file and don't change anything you don't understand. You need to run the update-grub command for the settings to take effect.

1

You need to get Windows to show up in the GRUB boot menu. When the computer turns on, you should get a brief screen with boot options; it may say something to the effect of "Press Esc for options, starting in 3... 2.. 1..". Press ESC when prompted, and see if Windows 7 is on the list. If it's not, you'll have to add it yourself. The exact process to do this will depend on your system configuration, take a look at these postings.

1

If you don't want the Ubuntu installation you can insert your Windows CD and repair the bootloader. Once you are back in Windows you can use easybcd to manage Windows bootloader and have the options to select OS. http://easybcd.en.softonic.com/

Next time use Wubi which installs Ubuntu along Windows in a hassle free way.

1

I had exactly the same problem after installing Ubuntu 14.10 on a disk with Windows 7 on it. What solved it was running this command from Ubuntu:

sudo update-grub

That detected Windows 7 and added it to GRUB. Had to reboot twice, once past a "Missing operating system" message, but it worked in the end.

See also this question on Ask Ubuntu.

1
  • I just installed Mint on a laptop with Windows. Im not sure what went wrong but did no have windows in grub. I opened a command window and ran; update-grub worked for me, after rebooting I could select windows 7, it needed to scan my SSD for errors, after that it rebooted and when I selected windows 7 again windows loaded as it used to. Haven't used linux in about 10 years, so clearly I am not an expert this is just what worked for me. Commented Dec 28, 2016 at 17:56
0

After booting into Ubuntu, open up a terminal and type the following commands - sudo os-prober sudo update-grub

Picked up from https://wiki.ubuntu.com/Grub2#Commands They have helped me thrice when I borked my grub!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .