0

No matter what the TERM variable is set to, vt-100, xterm, xterm-color the terminal does wierd things, like force a carriage return after 80 characters, and only address the upper left corner of the screen.

It's very odd.

Curses is well named it's been the irritation in my side for 25 years of nix development.

migrated from stackoverflow.com Aug 22 '10 at 8:56

This question came from our site for professional and enthusiast programmers.

  • Maybe your question will be better in superuser.com – Erik Escobedo Aug 22 '10 at 0:48
  • or unix.stackexchange.com – Eli Frey Aug 22 '10 at 0:53
  • Indeed, that does sound very odd, because I've a stock Terminal.app on Snow Leopard which I use to log into many different Linux distributions roughly in my day to day work, and I've yet to come across any such issues. I have the terminal declared as "xterm-color", which doesn't seem to work for you, though. – ayaz Aug 22 '10 at 18:05
0

You didn't specify what terminal software you are using in OSX.

But if you happen to use OSX's default Terminal, then go to "Preferences -> Settings -> Advanced" and change "Declare terminal as" to "rxvt".

This has solved many problems for me, maybe it helps in your case as well.

0

Is your shell bash?

What does this print:

$ echo LINES=$LINES COLUMNS=$COLUMNS

Does running this help:

$ shopt -s checkwinsize

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.