My friend is having trouble installing Company of Heroes and CoH: Opposing Fronts under Windows 7. A few percentages into the installation, when the C/C++ runtime is being installed, the install fails with the following message:

An error occurred while installing the Windows Installer package "C:\Users\...\AppData\Local\Temp\...\...\vcredist.msi". Error code 10212:00000659: MsiInstallProductW returned 00000659: This installation is forbidden by system policy. Contact your system administrator.

We have tried:

  • Making sure that any previous installations have been completely removed, including searching and deleting any files/folders/registry entries matching "THQ" (the publisher) and "Relic" (the developer).
  • Installing into a brand new user account
  • Running Setup.exe as administrator
  • Running Compatibility check for Setup.exe, which suggested Windows XP but failed when trying those settings out

Things to note:

  • Microsoft Visual C++ 2005 is already installed - My theory is that the installer is trying to install an older version of the runtime, and that Windows 7 says "No you don't!". Also, the download pages for those files says they are for Windows XP, etc, but not for Windows 7.
  • Downloaded the C++ 2005 SP1 redist, but that install fails just the same
  • The logged in account is an administrator account, but I still tried the "Run as admin" option. Also, the newly created account mentioned was an admin account.

I think the issue is more related to the Windows Installer than the game itself.

Does anyone know what might be the cause of the system policy error?


I found this answer on the Relic News forums which basically suggests installing the vcredist file manually:

see the directory path in the error message? its probably because the difference between the temp directory in 7 and XP (i don't know, i'm just gamefreak).

so, in the game folder, open "data" folder, look for the "vcredist.zip" and extract both files in the same folder. after that, double click "vcredist.msi", browse path of the file itself. it will install the software-that-cannot-found-in-temp. after finish, you can continue installing the game.

  • I know its been a year but this is still helping people, thank you :) This fix also works for error code 10212:0000064c ("The installation source for this product is not available.") – Aralox Jul 6 '12 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.