Any idea what's causing this issue and how I can resolve it?

The biggest clue here is that I can boot fine when the SATA controller is in SATA or AHCI mode, but on selecting RAID booting throws an error. I've already enabled MSAHCI and iaStorV RAID drivers from the registry.

  • I have an ASUS M3A76-CM board with the AMD 760G chipset.The SATA controller has 3 modes: SATA, AHCI, and RAID.
  • I have Windows 7 x64 installed to an SSD
  • Other drives: 2TB and 2x1.5TB in RAID1 (ideally)
  • It boots perfectly well when the SATA controller is set to SATA or AHCI
  • When the SATA controller is set to RAID, everything goes as planned up 'til the OS choice screen

At that point I get the error below:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

1 Insert your windows installation disc and restart your computer.
2 Choose your language settings, and then click next.
3 Click “Repair your computer.”

If you do not have this disk, contact your system administrator or computer manufacturer for assistance.
File: \Windows\system32\winload.exe
Status: 0xc000000e
Info: The selected entry could not be loaded because the application is missing or corrupt.
Enter=Continue Esc=Exit

Switching back to SATA/AHCI controller mode works perfectly every time, except of course that I need RAID. Obviously, there is no issue with winlogon.exe, or W7 wouldn't start. I've tried:

  1. Startup repair (recognizes install, says it fixed it, but same error fires at startup)
  2. bootsect - all options
  3. Rebuilding the BCD from console in repair mode
  4. Rebuilding the BCD with EasyBCD

You cannot simply switch the bios to raid and expect it to work, the raid array has to be set up in advance, and the OS installed clean installed to the raid array, you cannot switch between raid and non raid.

Creating a raid array will wipe all data on the drives chosen for the raid array.

unless I misunderstood your post.....

  • I think you may have misunderstood. The 2x1.5TB RAID 1 array is blank and will be used solely for storage -- it'll have nothing to do with my OS. I'm just trying to add it to my config, and I've already enabled the RAID driver via registry in Windows 7. Hence the befuddlement. – tunack Aug 24 '10 at 11:00
  • Once you enable raid, check boot priority, be sure the non raid disk is first. Some bios's have two sections for boot devices, one is called boot order, the other is boot priority. – Moab Aug 24 '10 at 16:54
  • Have that set up correctly as well -- I get to the Windows 7 bootmanager just fine (it resides on the non-raid OS disk) with RAID enabled. On selection of the OS, I get the winload.exe error -- strange, huh? – tunack Aug 25 '10 at 21:39
  • I am still a bit confused, you say the raid array is for storage only? If so you cannot add it to the boot config because it is not a bootable array. – Moab Aug 26 '10 at 2:26
  • I think you need to start over completely if you need raid, you would need to enable raid in the bios and then clean reinstall the OS and load the raid driver during setup. If an OS is installed in AHCI mode, it will lack driver necessary to boot with the bios set to Raid. – Moab Aug 26 '10 at 2:31

Fixed it.

Used a clean install on the RAID array to patch my existing install.

  • -1 How is a clean install a patch on your existing install? – barlop Jun 2 '14 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.