11

I'm trying to set up django on a fresh Ubuntu VM. I'm following the tutorials along until I get to this:

psycopg2.OperationalError: FATAL: Ident authentication failed for user "postgres"

The Ubuntu user "postgres" has had its password set to 123456:

sudo su postgres -c passwd

Using pdadmin, I connect to the pg instance at localhost, go into Login Roles, right click on the user 'postgres' and set the password to 123456. I then click OK and exit pgadmin3.

But, even after doing all this,

psql -U postgres -W

rejects the password I have given it. Django also continues to give me the same error even though settings.py has been setup with the correct info.

Anyone have any ideas?

12
+25

This article and its comments might help:

“FATAL: Ident authentication failed”, or how cool ideas get bad usage schemas

  • I had to reload pg_hba.conf after changing it...e.g. while logged into postgres: SELECT pg_reload_conf(); – Craig Sep 26 '18 at 21:31
3

change IPv4 local connections to trust in pg_hba.conf.

# IPv4 local connections:
host    all         all         127.0.0.1/32          trust

i hope it helps you...

  • 3
    This is allow ALL local users connect without passwords to Postgres. This is bad idea – b1_ Oct 29 '12 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.