1

I'm seeing network packet duplication for traffic between guest and host on several machines that use an ASUS ROG STRIX B650E-E GAMING WIFI motherboard in their builds. This board comes with an Intel(R) Ethernet Controller (3) I225-V physical NIC that is used in virtual machines as a network adapter in bridged mode. The board contains the third revision of said chip (as indicated in its name and Windows device information).

Several protocols are affected (assuming all), most notable in my case being SNMP.

A simple single ICMP ping produces traffic such as below in Wireshark (both the ping and capture take place on guest, guest pings host):

"1","2023-07-06 11:00:55,827524","10.0.3.109","10.0.0.249","ICMP","74","Echo (ping) request id=0x0001, seq=5/1280, ttl=128 (reply in 2)"
"2","2023-07-06 11:00:55,828060","10.0.0.249","10.0.3.109","ICMP","74","Echo (ping) reply id=0x0001, seq=5/1280, ttl=128 (request in 1)"
"3","2023-07-06 11:00:55,828060","10.0.0.249","10.0.3.109","ICMP","74","Echo (ping) reply id=0x0001, seq=5/1280, ttl=128"

This is happening on every guest operating system in a consistent manner, but only with this particular Ethernet chip. When using an alternative hardware NIC that is not Intel based, everything works as expected. Machines that use different hardware NICs are not affected. Outgoing traffic (host to another physical machine) is not affected. VirtualBox virtual machines are not affected so this appears to be a VMware only thing. Duplicated packets are reported by several different programs, not just Wireshark, so the packets are actually being duplicated somewhere by something.

Is this a known issue and can it be resolved in a way that excludes using a different hardware NIC?

VMware Workstation 17 Pro (17.0.2 build-21581411)
Windows 11 22H2 (22621.1702)
Intel(R) Ethernet Controller (3) I225-V driver ver: 2.1.3.3, 2.1.1.7

Note: the two driver versions are the latest one provided by Intel (2.1.1.7) and the latest provided by ASUS (2.1.3.3) at the time of writing. The issue occurs with both versions of the driver.

Edit: switching network adapter settings to use NAT resolves the packet duplication issue between guest and host, however doing so also introduces other problems for my use case, so I'd like to avoid doing this.

Edit: tried setting the Routing and Remote Access service from Disabled to Manual, then starting and stopping the service as suggested (this service had never been Enabled prior to this attempt). The issue persists. Tried multiple times, even ran the ping test in all possible states of the service to no avail. The reply is always duplicated.

9
  • Are you using the current drivers for the device?
    – Ramhound
    Jul 7, 2023 at 12:38
  • @Ramhound yes, 2.1.3.3 is the latest available driver for the NIC at this time. Same goes for other hardware on these machines.
    – predi
    Jul 7, 2023 at 12:43
  • Newer drivers than that seem to be available here
    – Ramhound
    Jul 7, 2023 at 12:57
  • @Ramhound that would install the 2.1.1.7 version of the driver (see release notes). The latest version is provided by the manufacturer of the board here. Both versions reproduce the issue as indicated in the question.
    – predi
    Jul 7, 2023 at 13:10
  • 1
    Even if RRAS is always disabled or not running, make sure to try and manually enable/start the service, then stop/disable it anyways. Some people had success with that here, though the comments suggest it may be temporary: thedatamachine.wordpress.com/2019/12/26/…. As an alternative, vmware does offer complimentary support for 30 days after registration, so check with them too if possible
    – Cpt.Whale
    Jul 10, 2023 at 14:30

0

You must log in to answer this question.

Browse other questions tagged .