I am trying to "burn" the ISO recovery media file from Paragon Hard Disk Manager to a USB flash drive, but balena Etcher warns:

The image does not appear to contain a partition table, and might not be recognized or bootable by your device.

enter image description here

Indeed, I have not been able to boot from the resulting USB flash drive.

What could be the issue and how can I get it to be bootable?

  • Using Paragon Hard Disk Manager (version 17.10.2) Recovery Media Builder
  • Paragon can output to an ISO file or removable flash media (eg. USB flash drive)
  • Building directly to a USB flash drive is bootable
  • The ISO file is bootable by a (VirtualBox) virtual machine when connected as a live CD/DVD

2 Answers 2


A workaround is to use Ventoy to create a bootable USB flash drive which can then in turn boot the Paragon ISO file. An added benefit is that multiple ISO files can be contained simultaneously on the USB flash drive.

Another solution could be to use isohybrid -u [ISO filename] on linux to make the ISO 9660 file a hybrid ISO. This has worked for me with other ISOs, but in this case I was getting an error "unable to find efi image". Since Ventoy got the job done I didn't investigate further.


Balena etcher wants an iso which looks like a "linux distro" iso.

The Paragon one is built on something else (WINPE).

You could use another software to write the iso in block mode, like Rufus in DD mode (if you're on Windows) or just use dd (on Linux) to write directly on the USB drive

  • 2
    Hello, there are too many "might"s in your answer relatively to other content. I personally wouldn't trust it.
    – Destroy666
    Jul 11 at 6:57
  • 1
    Indeed there were too many "might", my bad
    – Venix
    Jul 11 at 7:05
  • I didn't mention it, but Paragon's recovery media can be either linux-based (Ubuntu) or WinPE-based. Both ISOs exhibit the same problem. I tried using dd in linux (or the Disks gnome-disk-utility), but the result is the same as with Etcher: not bootable. Disks shows the USB flash drive contents as "ISO 9660 (version Joliet Extension)".
    – adatum
    Jul 11 at 7:08
  • If you mount the USB on Virtualbox, in passthrough, can you boot from it?
    – Venix
    Jul 11 at 7:14
  • How can I boot from a USB flash drive on Virtualbox? It appears that is not natively supported and there are convoluted methods to get it to work in some cases, by using a different boot manager (Plop Boot Manager), and only with EHCI / USB2, not xHCI / USB3: askubuntu.com/questions/693719/…
    – adatum
    Jul 11 at 16:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .