last week my DVD drive failed (or so i thought) i ordered a new one and fitted it today only to find that the same problem still persists.

I have 2 DVD drives, the new one thats a SATA DVD/RW and an old one thats an IDE DVD (kept in to copy from).

When i put disks in the new reader it spins up but windows never sees it, but the same disk in the old drive works fine (Tried a written disk, DVD and Game). So its only when trying the new Drive. Windows has definitely seen it properly (right click -> eject works).

At first i thought it might be a driver issue, new drive is almost identical to the old one apart from being SATA so i removed the driver and got the latest one from windows update, still no joy.

Next thought was is the new drive duff as well (could happen) so i tried booting to it, no problems there.

So the drive is fine its just windows that wont read the disks.

I do have a RAID array in my machine, but i can't see that being a problem.

  • Try here i think its what your looking for. Sounds like you have installed a program that takes over the drives, and auto insert is off by default.… – user47212 Aug 23 '10 at 16:47
  • ... its not an autoplay issue, if it was i would be able to browse the disk and would have no problem. the disks never appear – Arcath Aug 23 '10 at 16:50
  • -1 for not reading the question – fbstj Aug 23 '10 at 17:02

What other media software do you have installed? That might sound dumb but stuff like iTunes and various DVD software can really do crazy stuff to your computer.

What motherboard do you have? I know my ASUS has special RAID SATA ports that need special configuration to work properly with a standard drive.

Also check here because just about any solution I can think of is listed. Basically, check for UpperFilters, change drive letter, remove iTunes, update the firmware of the drive, update your BIOS.

I think it is a Windows 7 problem. I also have 2 DVD R/RW drives that sometimes cannot be seen by the OS. I also had Vista on the same system so I rebooted into that, and both drives worked well. As to a solution, one of my drives is a Samsung drive and the other an HP. HP does not make a new driver for OS 7, Samsung drive is not supposed to be Windows platform dependent (it should work). I've not seen any answers from any of the companies (Windows, HP or Samsung). Let me know if you find an answer, cause I am tired of looking. DrmDznr

Be sure to check Device Manager as well ... are the drivers active? Does DM see the drives? Are there any logged errors, etc? Try deleting the drivers and unplug them both. Reboot. Then shutdown again and plug in ONE drive ... preferably the SATA drive ... start up and let the drivers load. Then shutdown and attach the IDE drive ... and -- if the drive is found -- let the drivers install. That might work.

I don't remember the details, but I remember reading somewhere that SATA and IDE devices of the same type don't necessarily work well when loaded together on the same mother board ... if I remember, it had to do with the chipset and the way the OS handled the I/O request. IDE is very old technology and W7 is the newest and best ... there could be a backwards compatibility issue and the chipset-OS combination doesn't like both SATA and IDE drives attached at the same time.

Just something else for you to look into. Good luck!

I had a similar experience with a Windows XP box after installing, uninstalling and reinstalling various DVD-related software.
The problem (as user4750 suggested) is that software like Sonic, Nero, iTunes and many others install "filter" drivers to interpret the data from the drive, but sometimes these upper- and lower-filters can conflict with each other.

So you may need to uninstall any CD, DVD or music related software to remove these filters. Microsoft offers a tool which should sort out any configuration problems, but it never worked for me on an XP system. It may do the job on yours.

In my case, I found that after booting from a LiveCD, Ubuntu could recognize and read the drive just fine, so I knew it wasn't a hardware problem. If you have access to some other O/S on a bootable CD/DVD, you might like to try that.

That Microsoft link above also contains this suggestion:

  1. Click Start, and then click Control Panel.
  2. Click System and Security, click System, and then click Device Manager.

    Note If Control Panel is in Classic View, double-click System, and then click Device Manager.
    If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

  3. In Device Manager, expand DVD/CD-ROM drives, right-click the CD and DVD devices, and then click Uninstall.
  4. When you are prompted to confirm that you want to remove the device, click OK.
  5. Restart the computer.

If that doesn't work, things will get messy.
For earlier Windows versions, Microsoft recommends removing the Upper and Lower filters from the Registry, and you can do that by saving this text below as a .reg file, and merging it in.

Windows Registry Editor Version 5.00


Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.