I haven't really paid attention to Flash for uploading, but lately I've come across a few websites that use exclusively flash uploaders.

I can't use Flash Uploaders, nothing happens. I have Firefox 3.6.8 and the latest Flash Plugins.

For instance http://imgur.com/, when I use their flash upload, nix, nada, zip, zilch. Same story with YouTube. It hasn't bothered me so far, because I always could switch to html, but like I said, a few websites use flash uploader exclusively.

Anyone know WHY it doesn't work and have a solution?

Strange thing though using IE8 with the same flash plugin version works just perfect.

  • 3
    Define what exactly "nothing happens" means. Is there a blank space? Does it do nothing when you press upload? What does Firebug/Flashbug say about it? – Hello71 Aug 23 '10 at 19:51
  • IE8 is not using the same Flash plugin. The same version, yes, but there are two different plugins, one for IE and one for all other browsers. Speaking of plugins, what plugins/addons do you have for FF? – CarlF Aug 23 '10 at 20:50
  • Nothing happens, means nothing happens. Nothing, like not uploading. Nix, nada, zilch. I don't do Firebug/Flashbug btw. – Grumpy ol' Bear Aug 23 '10 at 23:05
  • Plugins I use: imgur.com/16APy.png – Grumpy ol' Bear Aug 23 '10 at 23:06

Firefox runs flash as separate process (plugin-container.exe) as a means of crash protection. See if your firewall is blocking this process.

Also try disabling this mechanism. http://www.technogadge.com/how-to-stop-firefox-plugin-container-exe-process/

  • HOLY F'KING SHIZZLE!! IT WORKED! It was my firewall...FML! Thank you! – Grumpy ol' Bear Aug 31 '10 at 8:32

The following article has two possible solutions: Flash bug in Firefox.

The two solutions involve unloading an installed PKCS module (public-key cryptography standards), which was installed inadvertently and creates a problem with Flash.

First method: Go to menu "Tools -> Options -> Advanced -> Encryption”. There click on "Security Devices", then on all installed PKCS modules and then click Unload. Restart Firefox.

Second method: Rename the “secmod.db” file from your profile directory (eg. "C:\Documents and Settings\YourUsername\Application Data\Mozilla\Firefox\Profiles\?????.default" or "C:\Users\YourUsername\AppData\Roaming\Mozilla\Firefox\Profiles\?????.default") which will be recreated with the next restart of the Firefox browser, but with only the PKCS modules which are installed by default.

If this doesn't work, this article might help to completely uninstall and reinstall Flash.

  • Nope, neither solution works. – Grumpy ol' Bear Aug 29 '10 at 19:54
  • @NoCanDo: Did you try completely uninstalling? – harrymc Aug 30 '10 at 6:03
  • Yes...the only thing I can think of now is a complet reformat of my HDD C: but Firefox ain't worth it ;). – Grumpy ol' Bear Aug 30 '10 at 9:43

Keep in mind that the flash plugin for Firefox and the flash plugin for Internet Explorer are actually separate installs, because the plugin architecture is different for each of them. I would recommend trying to uninstall then reinstall the flash plugin for Firefox, which you can do from the control panel. Another troubleshooting step would be to start Firefox (not Windows) in safe mode, and see if that works. If so, it may be an issue with one of your addons. Finally, does it work in any other browser besides IE? Chrome, for example, uses the same plugin architecture as Firefox, so you could try it there.

  • Nope, doesn't work. I tried Chrome, works perfectly with Chrome. I disabled all addons in Firefox, still wasn't working. Even startet Firefox in Safemode.Reinstalled Firefox. Nix, nada, zilch. – Grumpy ol' Bear Aug 29 '10 at 19:55
  • Very odd. When you reinstalled firefox, did you have it completely wipe your firefox user profile? Does it do this on all user accounts on the computer? – nhinkle Aug 29 '10 at 20:08
  • Yes on new profile, yes on all user accounts. – Grumpy ol' Bear Aug 30 '10 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.