0

I have Windows 10 business with hyper-v Version: 10.0.19041.1. I normally start an Ubuntu 22.04 VM on hyper-v and it takes me to the xrdp screen where I can chose settings like shared drives and screen resolution etc and then log in. When I log in it skips the normal Ubuntu log in screen.

I have not changed any settings in Hyper-v or Ubuntu recently but today I started the VM and it went to the normal Ubuntu log-in screen (normally this is skipped cause I log in through xrdp). The xrdp screen did not appear at all which means that I now can't change settings like screen resolution etc.

Here's the catch: months ago I installed the xfce desktop but was not able to select it because the option to select is on the Ubuntu log in screen. I can now select it which is great but I can't change the xrdp settings like screen resolution etc.

Is there any way to have my cake and eat it here so that I can do things like change the screen resolution but also change what desktop environment I use?

Being able to the change xrdp settings are way more important than changing the desktop environment so if it is not possible to do both then I really need to know how to change the xrdp settings again?

5
  • I am looking at my Hyper-V setup. How did you establish an XRDP login? What setting in the Hyper-V Manager?
    – John
    Jul 18, 2023 at 12:18
  • @John It's just how it's always been for me so I don't know. I have just had a look through settings and nothing jumped out at me as connected in anyway. Do any for you?
    – ojunk
    Jul 18, 2023 at 16:11
  • @John Hyper-v Version: 10.0.19041.1
    – ojunk
    Jul 18, 2023 at 16:12
  • I have Hyper-V 10.0.25905. There is no Hyper-V setting to start with XRDP. This was something in your Ubuntu machine and nothing to do with Hyper-V. My guess is changing the desktop in Ubuntu wiped out what you had.
    – John
    Jul 18, 2023 at 18:12
  • I started Ubuntu 22 in Hyper-V and there is nothing special there to start it in XRDP. . So not at all Hyper-V related.
    – John
    Jul 18, 2023 at 18:27

1 Answer 1

0

I have several Hyper-V Linux machines including Ubuntu 22.04.

There is no setting in Hyper-V to start a Linux machine with XRDP.

This was something you added with the XRDP setup:

Install xrdp (sudo apt install xrdp)

Enable xrdp (sudo systemctl enable xrdp)

Start the xrdp service (must be started each time Guest is started): sudo systemctl start xrdp

Check with status.

If you cannot get back to the settings you installed, then either use as is, or build a new Ubuntu machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .