0

I have a blue snowball usb microphone, and it shows up in device manager under "Sound, video, and game controllers". However, when I go to the sound control panel, under the "Recording" tab, the blue snowball does not appear. No application detects the Blue snowball microphone as an audio input device, so I cannot use it.

Unfortunately I do not have admin privileges on this machine. Even when I unplug it and plug it into different USB ports, or restart the computer, I have the same problem and still cannot use it.

I am not sure why Windows isn't detecting it in the sound control panel but it is in device manager. Any idea of what I should try?

I'm on Windows 10 21H2.

5
  • Have you installed the drivers? You'll probably need admin perms to do that. support.bluemic.com/hc/en-us/articles/…
    – Tetsujin
    Jul 19, 2023 at 15:15
  • @Tetsujin, no, but this microphone has worked fine on four other Windows laptops without the driver installed. There is something up with this one. I'm guessing there might be some other drivers or something interfering with it. Jul 19, 2023 at 15:25
  • Blue themselves are probably best source for assistance - though you're going to need admin perms at some point.
    – Tetsujin
    Jul 19, 2023 at 15:27
  • Was any of the other computers of exactly the same model as yours? If not, please add the models of the computer and mouse to your question.
    – harrymc
    Jul 19, 2023 at 16:35
  • @harrymc, two of the others were dells, two of the others were HPs, and this one with the problem is lenovo. Jul 19, 2023 at 16:54

2 Answers 2

0

I had exactly the same problem with my Razer Seiren Mini.

Try to:

  • open settings > Devices
  • find your microphone
  • remove it
  • unplug and reconnect again

Try this if uninstalling/updating drivers in device manager didn't help.

0
  1. Device Manager
  2. Locate Mic
  3. (R) Click Uninstall Device
  4. Unplug device
  5. Restart
  6. Plugged in USB mic after logged into Windows
  7. This is what fixed it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .