Yesterday I noticed Komodo Edit (32-bit) being unable to create new folders in the Open File dialog; I got a Windows shell "Access denied" message box with "C:\ is not accessible. Access is denied.".

Trying to navigate to C:\ in the dialog also fails with the same message. Using Komodo's built-in "Quick Open" also fails for C:\, but for example C:\Python25\ works fine.

The same issue is apparent in WinSCP (relevant WinSCP forums thread), but for instance the 32-bit Notepad is fully able to create folders and navigate to the drive root.

Other drive roots work fine in all programs, and I can't see anything that would differ in their NTFS ACLs. Also, when running Procmon to see what's going on, all I get there is an "ACCESS DENIED" result for the, ah, offending drive.

The issue also does not appear when running the programs as administrator, but I don't really want to do that for a text editor.

Anyone with the same trouble and/or any hints?

EDIT: For those capable of deciphering these, here's the icacls output for the "broken" drive:

c: NT SERVICE\TrustedInstaller:(I)(F)
   NT SERVICE\TrustedInstaller:(I)(CI)(IO)(F)

And for a working drive:

x: BUILTIN\Administrators:(F)
   NT AUTHORITY\Authenticated Users:(M)
   NT AUTHORITY\Authenticated Users:(OI)(CI)(IO)(M)

3 Answers 3


I think it has something to do with UAC. Does it work when you disable it?

  • I would imagine it does, as running the problematic programs as administrator indeed makes them work as intended.
    – AKX
    Aug 24, 2010 at 9:23

By default, write access to the root of C is restricted (not other drives) - including the creation of folders. However, this shouldn't prevent read access, I wonder if the program is not using the relevant Windows API's?

Anyway! To get around this run the software as an administrator - right-click the relevant program/shortcut before running you can select Run as Administrator to elevate the software (for that single run) to allow you to do this - you will have to confirm a UAC prompt.

Also, if you right-click the exe for the software and look at the Compatibility tab ,there is a Run as Administrator option. Enabling this will automatically elevate on every run, if that is what you need.

I would recommend against disabling UAC generally, doing so lowers the security of your entire system.

  • Good reply, but I did mention I don't want to elevate a text editor to admin status -- also, it has worked correctly before yesterday.
    – AKX
    Aug 24, 2010 at 9:20
  • @AKX - My apologies, as I clearly didn't read your question in sufficent depth. As for the change being yesterday - have you recently installed anything, updated the software in question or updated Windows? Might be worth looking at recent System Restore points (although, not necessarily rolling back to them unless you see anything that looks like it could be the cause).
    – DMA57361
    Aug 24, 2010 at 9:51
  • The only restore point lately before today (installed PHP for development) is from the 20th, for a Windows Update... Reviewing the windows update history says it was a Windows Defender definition update. The problem MAY have started before yesterday though, but I'm pretty sure I would have noticed it.
    – AKX
    Aug 24, 2010 at 10:10


The installer of the E text editor had botched up the permissions of the drive while installing Cygwin.

  • Could you elaborate on what you did to fix the permissions? Did you simply do a System Restore to a previous point before the permissions screw up? Oct 3, 2012 at 7:43
  • Unfortunately I can't remember anymore. Should have added what I did in the original answer back then...
    – AKX
    Oct 3, 2012 at 10:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .