5

When you put your mouse cursor on the task bar or desktop switcher and roll the scroll wheel it switches between applications or desktops (sorta like when you alt-tab). This is all well and good however I find it to be very irritating because it always happens on accident (I am on a laptop with a touchpad). How does one go about disabling this feature?

I'm using Ubuntu 10.04 with gnome. Nothing fancy.

Thanks in advance.

0

As written by linunix @ https://www.reddit.com/r/ManjaroLinux/comments/ha2w1r/how_do_i_disable_switching_between_windows_when/fv0cb6c/?utm_source=reddit&utm_medium=web2x&context=3,

If you're indeed using Dash-to-Panel (version 40 here) under GNOME, right-click on the Show-App icon (enter image description here) of the task bar and open "Dash-to-Panel settings", then go to Action tab and change the setting from "Scroll icon action" from "Cycle window" to "Do nothing".

enter image description here

Had to struggle with that one a bit too.

0

By default, (on Ubuntu 18.04) viewport switching is bound to a horizontal two-finger swipe. The sensitivity is very high, so when you scroll vertically you also easily scroll horizontally accidentally.

Disabling horizontal scroll was also more of a hassle than I expected (e.g. dconf-editor and ccsm didn't do the job). libinput-tools did it for me though, see further instructions:

https://askubuntu.com/a/1130184/1034363

-1

best answer I can find. I wish this was just a setting in gnome though: https://bugs.launchpad.net/gnome-panel/+bug/39328

1
  • That's a very lenghty discussion, and contains only touching information – JBSnorro Jan 27 '20 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.