I am using Windows XP SP3 and Windows 7. On both machines, I cannot make Hiragana the default input method. Is there a way to do this?

In the IME tool bar, there is the option to set the "Input Mode." This is always defaulted to "Direct Input." I would like to default to Hirgana or Katakana. I have found the setting dialog for this, by right clicking on the IME toolbar -> settings -> Japanese IME Standard -> Properties -> Default Input Mode. This setting seems to have no effect, no matter the combination of selections in the dialogs.

Is there a way to reliably set the default Input Mode?

  • I have found that even though it shows half-width alphanumeric, it will switch to Hiragana as soon as I click in a textarea to type. – mbomb007 Jun 26 at 1:26
up vote 14 down vote accepted

Unfortunately, there is still no way to do this in Microsoft IME. Instead, Microsoft support suggests that you can use the hotkeys to switch between input modes quickly:

  • Press Alt + Shift to change the input language
  • Press Ctrl + Caps Lock to change to Hiragana
  • Press Alt + Caps Lock to change to Katakana
  • Press Alt + ~ to toggle between alphanumeric and kana modes

As a side note: if you were really intent on making Hiragana your default input, you could write an AutoHotkey script to do this for you. However, this involves understanding that scripting language.

This is a workaround that has worked for me: instead of using the default hotkey (usually Alt+Shift) for cycling through all installed input methods, set up a hotkey to switch to Microsoft IME directly. On both of my Windows 7 systems, switching to Japanese input this way at least remembers the last selected input method, so if you chose Hiragana input, it will default to it next time you activate IME.

Go to the input method settings and switch to tab Advanced key settings. In addition to the default hotkey to cycle between languages, the list should contain an entry To Japanese (Japan) - Microsoft IME. Click Change Key Sequence and set up a combination.

protected by nhinkle Nov 6 '12 at 3:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.