I have a small problem.

Today my Crucial c300 arrived. Now I want a clean install windows 7 64 bit. After firing up the dvd, I get a screen which says that it needs drivers for my hardware. Why cant I install?

I have the following specs

Biostar i55 motherboard sata 1 - Crucial 3ooc sata 2 - CD/DVD drive

Processor Intel i860

I tried the following, pff where shall I begin

bios settings:

sata -> ACHI sata -> IDE sata -> RAID0

Downloaded the ACHI/RAID drivers from the website of Biostar for my motheboard and copied it on a usb device, and pointed the browser of the windows 7 installation guide to a compatible driver, no luck.


It seems that your BIOS settings might be wrong. If there is a RAID0 I would usually just set the ACHI sata to RAID = depending on your mother board. However there might be a problem of the Motherboard with the new hard disk you just bought. I would suggest you upgrade the motherboard firmware and BIOS version too.


The copy of the windows 7 version I used was badly burned, I burned a new one on 22 KBPS and I could install Windows 7 64 bit without a problem. Same ISO.

  • just a thought - you might want to consider deleting the question... – hotei Aug 25 '10 at 1:22
  • Maybe this answer could be relevant to other people. I think it's best to let it be. I have spend 3 hours try and die, till i read something about a badly burned disk. I tried the same iso again, this time I used winiso to burn a new copy. No problems with installing. – Chris Aug 25 '10 at 15:27

I used novicorps wintoflash free program to install windows 7 64bit from the installation disk to my usb drive. Boots right up and loads right to the ssd drive fast!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.