0

I'm trying to get mosh.org work on Windows with truecolor (24-bit) support. Mosh includes truecolor support since version 1.4. However:


Then I tried to compile Mosh 1.4 from source on WSL. It compiled just fine:

% mosh --version
mosh 1.4.0 [build mosh-1.4.0-19-g1105d48]

I have COLORTERM=truecolor set. Truecolor support works locally within Windows Terminal, tested with https://github.com/termstandard/colors.

enter image description here

I also have

% cat ~/.ssh/config
SendEnv             COLORTERM

so that the variable propagates to the remote system.

When connecting via ssh, truecolor support works. But when connecting via mosh 1.4 (and also 1.3.2), truecolor still doesn't work.

enter image description here

Any ideas how to debug the problem further?

1 Answer 1

0

Turns out the solution is simple: The server-side mosh binary must also be of version 1.4+. With that fixed it works as expected!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .