19

I have this GDB TUI/layout on. How do I return to the default GDB view?

I can't just restart GDB, because I have important backtrace on my hand and as long as I have these extra windows I can't scroll well on the basic view.

17

You can enter / leave the TUI mode with one of this combinations:

  • C-x C-a
  • C-x a
  • C-x A

This is typically (no need to lift the Ctrl key):

  • Ctrl + X + A
| improve this answer | |
5

Beacause of the bug Ulerich mentioned which breaks the mappings if you have vi mode in your .inputrc, I have requested a workaround at https://sourceware.org/ml/gdb/2015-06/msg00009.html and Andrew Burgess replied that he had just submitted a well received patch to add:

tui enable
tui disable

so in future versions we should have commands as an alternative to the shortcuts.

I have later tested this on GDB 8.1 in Ubuntu 18.04 and it worked perfectly.

But then I saw the light and moved from TUI to GDB Dashboard which is simply more powerful and less buggy.

See also: https://stackoverflow.com/questions/8409540/how-to-close-layout-src-windows-in-gdb

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.