Overall Problem & Context:

My work laptop broke yesterday with no obvious cause. Symptoms were it would only boot to MSI Click Bios (its an MSI laptop) repeatedly. The OS was Windows 11. I've created a USB windows installation drive using Windows' "media creation tool" (run on my other windows laptop). I am able to boot from this USB and see the initial Windows installation menu. I have tried to diagnose and repair the issue from the "Repair your computer" menu on the USB boot drive. It seems the command line given there does not have admin privileges, so I'm limited in what I can do, but at least from what I can tell all of the computer hardware seems to be okay.

Current Roadblock:

When trying to reinstall Windows with USB I get an error A media driver your computer needs is missing. This could be a DVD, USB or Hard disk driver... etc.

Context on current Roadblock:

The USB installation drive was created twice, once with the Windows "media creation tool" handling everything including formatting the USB stick, and the second time with Windows "media creation tool" just creating a ".iso" file and then using Rufus to create the USB stick. BOTH METHODS produced the same error, described above.

One thing to note is that I did a disk check when using Rufus to create the USB and it found 305 corrupted blocks, but I believe that those were probably caused by this issue: https://github.com/QubesOS/qubes-issues/issues/2051

Also I'm pretty sure all my available USB ports are USB 3, but I'm assuming that an ISO for Windows 11 should have USB 3 drivers on it?

What I've tried regarding the Current Roadblock:

  • Using different usb ports (I have limited options there)
  • Enabling and disabling secure boot in BIOS
  • Multiple BIOS settings, ensuring Legacy USB mode, disabling quick boot, etc.
  • This: https://superuser.com/a/1789961/1706213

What I've tried to fix the overall problem:

  • Windows "Startup Repair" tool in the "Repair your computer">"Advanced Options" menu (just said "couldn't repair your PC" with a link to a log file that does not exist).
  • "Repair your computer">"Advanced Options"> Command Prompt -> with many different commands including:
    • chkdsk C: /f (resulting in "write protected" error)
    • sfc /scannow which says that it found corrupt files and successfully repaired them, but it says this every time after reboot with no discernable change. This DOES have a log file but I cannot export it from the broken computer unfortunately. The logfile summary says there were 1117 removal candidates (seem to be due to "no parent found") and 1 WinSxS Orphaned Objects Candidates... just incase that info is meaningful to someone (its not to me).
    • bootrec /fixmbr always returns immediately with The operation completed successfully
    • bootrec /fixboot = 'Access is denied.'
    • bootrec /scanos = 'Total identified Windows installations: 0' ( is this because its looking on the USB drive instead of the computer harddrive?)
    • bootrec /rebuildbcd returns same as scanos
    • bcedit /set {default} safeboot minimal to start from SSD in safe mode => Was still unable to boot from SSD, and so it fellback to the USB per BIOS settings.
    • dism /online /cleanup-image /checkhealth = "Error: 87 The cleanup-image option is unknown"

My Planned Next Steps:

  • Buy a new USB flash drive, although I doubt this is the issue as I'm using a Kingston I just bought yesterday
  • Build the USB boot disk with Balena Etcher instead of Rufus.


  • I've now replaced my SSD with a brand new one. Which is obviously a fix for whatever the original overall problem was, however, the "Roadblock" which prompted me to create this issue still remains. I still need to install windows and the Windows USB installation media does not seem to be working. Still getting the same driver missing error. Will update tomorrow.
  • It seems the USB boot disk CMD prompt DOES run as administrator, so I'll be playing around a bit more with that now. Commented Aug 22, 2023 at 17:07
  • 1
    "chkdsk C: /f (resulting in "write protected" error)" is a symptom of a deceased SSD. If you can boot and run entirely from USB, e.g., WinRE rescue disk like Hiren's or Ubuntu Live USB, then the internal drive likely is the issue. Commented Aug 22, 2023 at 17:10
  • @DrMoishePippik The thing is I can use CMD prompt from my usb and view and open files in the SSD, so for that reason I thought the SSD must still be okay. But maybe its partially damaged which is why I can still see stuff. I will check out WinRE, haven't heard of it before. Thanks for commenting! Commented Aug 22, 2023 at 19:19
  • 1
    Boot using the Win11 install USB, wait for the first screen, then press Shift + F10 to open a cmd console. Verify with whoami that you're running as the nt authority\system account. Medicat USB and Hirens (the new one) have boot fix tools that can help too. See also superuser.com/questions/1285268/…
    – Paul π
    Commented Aug 22, 2023 at 20:35
  • 2
    @Sheldonfrith, on sign of SSD failure is becoming read-only (intentionally done to preserve data until it can be salvaged -- further writes would destroy that data). There are other reasons it can be read only; check online and check the drives SMART data. Commented Aug 22, 2023 at 22:03

1 Answer 1


Well unfortunately for people looking at this in the future, I did not encounter a solution that didn't involve spending money.

In the end I replaced my hard-drive, which solved the original problem, however with the new harddrive I still had the "roadblock" problem with the USB installation media... and I tried every solution I could think of or find on the internet to solve it.

In the end it was just that there was something wrong with my newly purchased USB drive, I bought another one and was able to install Windows with no issue on the new SSD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .