5

I have a weird problem with VNC server (UltraVNC) on windows 7. I can connect to the server with no problems and use it as it should be.

Until.. I try to launch some application with administrator rights (Run as Administrator).

When I do that, a full screen notification appears on the server machine "Are you sure you want to launch it with admin rights bla bla". At the same moment I get disconnected from the server and can't connect until that message times out and disappears by itself.

Is there any way to make it work without disabling that notification messages?

Thanks.

  • Do you have the latest UltraVNC version? – Mikhail Chernykh Aug 25 '10 at 14:33
  • Yes, downloaded it yesterday. – bezmax Aug 25 '10 at 15:24
4

I think the VNC server is disconnecting you because Windows is changing your desktop to the secure desktop. This is when the screen dims and the dialog pops up. I believe this is confusing the VNC server, so it just dies. You can 'fix' this by disabling the secure desktop. On Windows 7, this is easy to do. Simply open UAC settings, and select "do not dim my desktop" (third one from the top).

4

If you install UltraVNC as a service, you can see the UAC notifications and press the buttons, on Windows 7 and Vista.

Also tick the "Download Vista addon files" option, when installing.

UltraVNC

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.