I have a Gigabyte H510M H motherboard with 4 SATA ports, which all of them either connected to a HDD or SSD drive. I decided to check my discs from 2012 and I realized since I upgraded my PC less than 10 months ago I never connected any DVD/CD drives to it.

So I disconnected one of my hard disc drives and used its cables to connect the DVD-ROM drive. I'm using Windows 10 and Pioneer DVR-219L CD/DVD-ROM/Writer.

The problem is the windows recognizes the device as optical drive, even shows its model and version.

enter image description here

also when I double click on it it opens the disc tray, but when I put a disc into device and close it, after 3-4 seconds of its LED blinking the whole device goes silent and nothing happens, even the message of Insert Disc won't disappear.

Insert Disc

I tried these and failed:

  • Updated my Windows 10
  • Installed latest BIOS firmware
  • Tried another cable and SATA port
  • Used another DVD-ROM which was IDE (using IDE ↔ SATA converter something like this yet the result is the same)

Both of these devices are working fine on other PC (which have a MSI-H61 motherboard and is older) and all of my SATA ports and cables are working fine with my HDDs/SSDs.

I want to find out where the problem is and possibly how to fix it, I'll appreciate any kind of help.


The device driver in CD-ROM and ATA/ATAPI category are installed and updated:

enter image description here

  • That drive is sooooo old that's most likely defective or, best case scenario, needs a serious clean-up. The same for the even older PATA drive. The year is 2023, not 2003!! Aug 26 at 12:28
  • @ChanganAuto thanks for your comment, how could I make sure the problem is only the device age? because the only thing that makes an old hardware unrecognizable for another piece of hardware is the driver. and in my case it seems the driver is ok and everything works fine! also as I said both of the DVD-ROMs working fine on older PC, and they have been regularly cleaned. Aug 26 at 12:33
  • Try resetting upper and lower filters. Not an exact fit here but try: ....... techsupportall.com/…
    – John
    Aug 26 at 12:54
  • @John Thanks for your response, I tried that registry trick, I didn't have those values! I also added the EnumDevice1 in atapi\Controller0 but nothing changed! Aug 26 at 13:05
  • I said both of the DVD-ROMs working fine on older PC That they WERE is plausible; that they ARE now working on one and not the other NOT plausible. Aug 26 at 19:18

1 Answer 1


The problem was with my connections, because I was testing it, I have the device outside of the PC case, and on a pile of books. This caused the device to tilt and disconnect in a way that just couldn't read the discs! I have no idea but my problem fixed. Thanks for all the comments.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .