When I open the Network folder inside Windows Explorer on my Windows 7 computer I see a list of computer names (most of them are Windows XP machines). If I double-click a Windows 7 machine it opens that machine and shows all of its shares. However, if I double-click on a Windows XP machine it hangs for about twenty seconds then returns the following error message:

Network Error

Windows cannot access \\Windows XPcomputername

Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.

Error code: 0x80070035 The network path was not found.

I can ping the Windows XP computer by name, I can connect to it from another Windows XP computer on the domain, I can double-click on the server machine and it will open correctly (running Windows Server 2003 for Small Business Server). I have been troubleshooting this for about 8 hours already (disabled my firewall, no help; disabled IPv6, no help; attempted to connect to IP address of Windows XP computer, no help; verified NetBIOS is enabled).

The thing I can't understand is that I was able to do this without any problem up until a few months ago. Something changed, but I don't know what. I have found several forums where Windows 7 users have reported this problem. Anybody have any new ideas?

UPDATE: I am able to connect to Windows XP computers on a different domain. (I do consulting work and I am a domain admin for several of my customers.) This makes me think that there may be some difference in network policy settings that is causing problems in Windows 7 <--> Windows XP communication/authentication.

UPDATE: The domain where I can connect to Windows XP computers uses DHCP. The domain where I'm having problems uses static IPs. On this problem domain my assigned static IP is in a different subnet ( than the computers I'm trying to connect to ( Could this be the problem?

UPDATE: If I ping my machine by name on the network where I am having problems, it resolves my name to an IPv6 address rather than IPv4. As far as I can tell, all the other computers on the network resolve to IPv4 addresses. Is it possible that my computer ended up in a name server with an IPv6 address and that is causing my problems? If so, is there any way to force the name server to store my IPv4 address instead?

  • What are your sharing settings set to?
    – nhinkle
    Commented Aug 25, 2010 at 20:04
  • On which computer? I'm a domain admin and am simply trying to connect to the hidden C$ admin share on the win xp computer. I know that it is available because I can connect to that share when I am logged in to another win xp computer.
    – mwolfe02
    Commented Aug 25, 2010 at 20:16

4 Answers 4


I solved this problem today on my LAN by disabling the "Use Sharing Assistant" option on Windows Explorer.

Steps (run on the Windows-7 client machine):

  1. Open Windows Explorer;
  2. Click the "alt" button to open the context menu;
  3. Click on "tools";
  4. Click on "folder options";
  5. Click on "Exibition Modes" tab;
  6. On "Advanced Configuration", the last item of the list may be "Use Sharing Assistant (recommended).

Disabling this item solved my network sharing between XP and 7. I also use static IP's on my LAN.

My setup:

  1. Server: Windows XP 32, static IP, Gigabit Ethernet;
  2. Client 1: Windows 7 64, static IP, Gigabit Ethernet;
  3. Client 2: Windows 7 32, DHCP, 100Mbps Ethernet or 811.G Wifi;
  4. Client 3: Same as client 1;
  5. Client 4: XBOX 360;

All of the clients are able to see the server with the config above.

EDIT: I also disabled IPv6 on all Windows 7 machines. Not sure if that could help at all.

  • Do the six steps relate to the Windows XP server, or the Windows 7 clients? Commented Sep 11, 2012 at 19:09
  • 1
    On the Windows 7 clients, I'll update the answer to clarify that.
    – Machado
    Commented Sep 11, 2012 at 19:32
  • Thanks, would you like me to make an edit that you may approve? I have an English version of Windows 7 here. Commented Sep 11, 2012 at 20:42
  • @Graham, feel free to edit anything you want to improve the answer. :) That's why we are here. :D
    – Machado
    Commented Sep 12, 2012 at 14:17

You might need to set-up your Windows 7 machine Sharing Settings for being abble to support file and printer sharing with an XP machine.

Here's a post that shows how to do that. Share Files and Printers between Windows 7 and XP.

  • I've isolated the problem a bit more and I'm fairly certain the problem is not my computer. It is most likely a network policy that is causing problems (see the update to my original question).
    – mwolfe02
    Commented Aug 30, 2010 at 12:57
  • you might need to Compare GPOs. For this purpose I think there aren't many tools available, I found 2 tools (couldn't find free tools) perhaps you coud try if using trial versions can help you. 'sdmsoftware.com/group_policy_compare' 'sysprosoft.com/pol_summary.shtml'.
    – Mario
    Commented Aug 30, 2010 at 15:28

I think that you have to make sure that both the Windows 7 PC and the Windows XP PC are on the same workgroup or domain even if they are connected to the same router, they will not be able to share folders. To change the Windows 7 domain:

1.. Click Start

2.. Right Click on Computer

3.. Find the section of Computer name, domain, and workgroup settings

4.. Click on Change settings

5.. Click on the box that says change to change the domain or workgroup of the computers

Note: It's easier to change the workgroup, since a DNS server doesn't have to be setup, but if you have a DNS server setup then you can change the domain easily. You'll also have to restart both computers.

To change the Domain of the XP machine follow this guide.

Good luck!

  • That's not the case. As I said in the update to my original post, I can connect to Win XP machines that are on a different domain (my own laptop is not joined to any domain...and I like it that way :). Also, if I try connecting from a Win7 machine to a WinXP machine that are both joined to the same domain, I get the same error. You're right that in general it is much easier to set up sharing when both computers are on the same domain/workgroup. But it is not a requirement.
    – mwolfe02
    Commented Aug 31, 2010 at 13:39

The issue is probably with the static IP setup. Can you connect to the static IP for those addresses? IE: \\

If that works, then you have a couple options. 1: set up DHCP to propagate these issues (lots of networking interconnects as for why this works), or 2: edit the hosts file on each computer to have the mapping set up for, say    xpcomputername    jimpc
  • Nope. Attempting to connect to the IP of the WinXP computer directly through Windows Explorer results in 'Unspecified Error.' I'm at a different location today so I can't test this now, but I recall getting a similarly cryptic error message when trying to connect using something like 'net use y: \\\c$' from inside a command window.
    – mwolfe02
    Commented Sep 2, 2010 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .