1

On Debian, in my apt sources I have put the source for opera-stable browser.

opera is updated very often on their repo, almost daily or every other day. That's very frequent and every time a large download.

Is there a way to skip its (somehow automatic) update for a specific duration or something similar by configuring apt in a specific way? Updating that package only once per month would be sufficient for me.

Opera is an example here, but there is other closed source software that I have in my apt repo that I would like to be managed in the same manner.

2
  • 1
    Are you looking for Excluding Packages from Apt-Get Upgrade?
    – harrymc
    Sep 30 at 12:02
  • Ok, hold is an acceptable option. I used to use + key stroke in aptitude to select upgradable packages and was disappointed that it installed also the packages in hold state. Your comment made me dig and I discovered the U key stroke instead of +. So Hold (= key stroke) + U is the answer for aptitude. Thanks. Do you know a way to remove the hold mark on a package after a specific duration?
    – usilo
    Sep 30 at 15:00

2 Answers 2

2

To exclude the Opera Debian package from updates, use the following command:

sudo apt-mark hold package_name 

This will turn off the updates of the specified package(s) from automatic upgrades and also from manual upgrades.

To undo the hold, use the following command:

sudo apt-mark unhold package_name 

For more information for Debian and other Linux distributions, see
Excluding Packages from Apt-Get Upgrade.

0
  • Hit the Super key (Win-logo),
  • type "update"
  • and click in the pinkish icon that appears (Software & Updates).
  • Click on the /Updates\ -tab in the top row.
  • Find "Automatically check for updates:" below;
    set it to anything you like.

You will most likely find it to be set to Daily, currently

1
  • Thank you, I guess your answer is with Gnome DE. I run KDE, but there is a similar configuration option with almost the same wordings. This doesn't exactly answer my problem but interested me as well.
    – usilo
    Sep 30 at 15:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .