A process with the following icon is preventing Windows 11 Pro for Workstations, 22H2, OS build 22621.2361 from shutdown and/or restart:

enter image description here

I've tried to identify it, but failed - there is nothing in the logs, no path to software, no name of the process. MS Process Explorer do not show any process with this icon.

Anyone would know what it is and how can I get rid of it?

  • Try SysInternals Process Monitor and also see if it is starting up using SysInternals Autoruns
    – John
    Sep 30, 2023 at 18:05
  • The shutdown message contains the name of the process. What does it say?
    – harrymc
    Sep 30, 2023 at 19:11
  • @John thanks, tried both, but this icon is nowhere. In meantime I found this: answers.microsoft.com/en-us/windows/forum/all/… which probably means I can be in deep troubles :(
    – Michal Gow
    Sep 30, 2023 at 19:11
  • @harrymc That icon above with text: This app is preventing shutdown.
    – Michal Gow
    Sep 30, 2023 at 19:18
  • Btw. followed suggestions there: answers.microsoft.com/en-us/windows/forum/all/… It is not graphic or scanner drivers.
    – Michal Gow
    Sep 30, 2023 at 19:24

2 Answers 2


I've upvoted LPChip's answer, because it have sent me the right direction even if his suggestion wasn't the source of the problem.

The issue was indeed connected with development - it was/still is an issue in Docker Desktop for Windows. Its update 4.23 (and all the following versions) breaks the shutdown: https://github.com/docker/for-win/issues/13697. (Notice the icon.)

It wasn't installed recently, hence I didn't suspect it, but after disabling background development tools the system started working again.

For all of you having the same issue, you need to close background Docker manually before shutting down.

  • So it's at least good news that it's nothing "nefarious"?
    – Tfovid
    Feb 10 at 22:39
  • Well, there always could be hackers using MS Visual Studio, but most likely when you see this icon it is Windows showing you where the the process source could be edited.
    – Michal Gow
    Feb 12 at 10:09

Given that you say it is a development machine, and the icon is the default icon for Microsoft Visual Studio, you are likely facing one of the things I had happen.

During development, your executable does not properly exit and remains in memory, as it is in a crashing/exiting stage during windows shutdown.

See if you can find your own application in memory, and if so, kill it, and see if that makes the problem go away. Another test you can do, restart your computer, don't open your development software and restart again, see if it happens, if not, open your development software, build and run it, and restart afterwards, should now happen again.

Do note, the icon in task manager will NOT be the one you see here. I don't know why that icon only appears in some places and not others if you don't set a specific icon in your program.

  • The icon has to be programmed. If this is a new project that code wouldn’t have been added yet. I agree it’s the authors own application that’s causing their problem. Since it’s not an executable being automatically ran. Furthermore, malware, is NOT coded in c# since it can be easily decompiled
    – Ramhound
    Oct 1, 2023 at 1:49
  • If only I'd do C# development. I do Python, PHP and JS. This seems to be indeed connected with .NET, but not my code. It must be connected with some software which requires .NET library, which became incompatible in time. But unfortunately none of Process Explorer, Process monitor, Autoruns or Windows Performance Analyzer gave me anything.
    – Michal Gow
    Oct 1, 2023 at 10:46
  • Do you convert your python scripts to an executable?
    – LPChip
    Oct 1, 2023 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .