0

I am trying to get RDP running to connect to my windows work laptop from my linux home PC. So far I got the best results with the RDP client itopia. My work laptop's AD is messy so regular authentication does not work.

This is my RDP file to enable me to authenticate after the connection was established (I get thrown into the windows logon screen instead of authenticating before/while connecting):

enablecredsspsupport:i:0
authentication level:i:2
full address:s:HOSTNAME

This was working perfectly when using the windows built-in RDP client.

Now on Linux I only got it to work with itopia without authentication and a good compression algorithm. The only issue I have is that it automatically sets the windows DPI scaling of the host to 150%. I want to keep it at 100%, otherwise I may as well not use RDP at all and just use the laptop regularly.

I tried adding the following settings with no avail:

desktopscalefactor:i:100
screen mode id:i:2
smart sizing:i:1
dynamic resolution:i:0

I also tried editing the registry on the host system:

In the registry folder HKCU\ControlPanel\Desktop I edited LogPixels to be 96 and Win8DpiScaling to be 0.

Any more ideas I could try?

1
  • I ended up using freerdp
    – lenny
    Commented Oct 14, 2023 at 16:53

0

You must log in to answer this question.

Browse other questions tagged .